FCP and MPIO - from the top?

Thank you for taking the time to read my post.  I've been involved in NetApp administration for 2 years and love it.  My environment includes NFS, CIFS, and iSCSI, but only 1 implementation of FCP.  I'm attempting to learn FCP and MPIO, but need some advice.

The following components make up my lab:

2 - Emulex 9802 cards

1 - Dell 1850 w/Windows Server 2003 sp2

1 - FAS270c

1 - Brocade Silkworm 200E fabric switch

I've read several of the block management docs.  I didn't exactly find a single doc that spelled MPIO with FCP end-to-end, but from what I could gather, this was my plan (in order):

1. Prepare filer (cluster, fcp, etc)

2. Install HBAs in the win2k3 server and load the Emulex Config Tool and HBAnywhere

3. Install FCP Host Utilities ver 5.3 and applicable hotfix(es)

4. Install DSM ver 3.4 and applicable hotfix(es)

5. Load Snapdrive ver 6.3 and applicable hotfix(es)

The physical configuration looks like this:

Dell1850 w/2-HBAs plugged into 2 ports on the Silkworm 200E

FAS270c plugged into 2 ports on the Silkworm 200E via 0c on both heads

I understand it's not true MPIO with a single FC switch, but it's all I have for a lab at the moment.

After loading all software, I used snapdrive to create LUNs on the 270.  I choose both wwnn's for MPIO.  Had SD manage the igroups.  In my mind, MPIO should be set up properly.

When checking under the DFM aplette in Computer Management, I see 4 connections to the filer.  (2 connections through 0c and 2 connections via the vtic/interconnect).  The problem is the state for each disk reads "Active/Unoptimized".  To test my disk, I ran an IOMeter test.  I tried to hit the disk pretty hard, and during the test, I received the following error from my filer's console:

"Sun Feb 27 14:24:50 CST [TOASTER1: scsitarget.partnerPath.misconfigured:error]: FCP Partner Path Misconfigured - Host I/O access through a non-primary and non-optimal path was detected."

When running a lun stats -o -i 1, the PARTNER READ KB is fairly significant (about 40% of the primary path).

Can someone let me know either what I'm doing wrong, what I'm leaving out, or what I might check to verify if my configuration is proper?  I didn't do any configuration via HBAnywhere or elxcfg.  Any help would be greatly appreciated.  Thanks again for your time.



Re: FCP and MPIO - from the top?

Did you enable alua on the igroup? since u did auto igroup handling with sd, i think alua is disabled.

try "igroup set <igroup> alua yes" and rerun your tests.

Re: FCP and MPIO - from the top?

DSM v3.4 ?

Is that the Microsoft DSM (not the NetApp DSM... ) ?

If using the native MS DSM ensure that Alua is enabled on the igroup.

When using the NetApp DSM leave it off ...

I hope this response has been helpful to you.

At your service,

Eugene E. Kashpureff
Senior Systems Architect / NetApp Certified Instructor

(P.S. I appreciate points for helpful or correct answers.)

Re: FCP and MPIO - from the top?

Thanks for your response Thomas.  Actually Snapdrive set AULA for the igroups.  I probably didn't mention it, but I verified that it was enabled prior to posting.  The installation of DSM tells you it's a requrement.

Re: FCP and MPIO - from the top?

Thank you Eugene for your response.  DSM 3.4 is NetApp's DSM MPIO.  Far as I understand, Windows Server 2003 requires a 3rd party DSM for MPIO with FCP.  I can do MPIO w/iSCSI without any issues.

How would I even go about check if MS DSM is installed?

Stop me if I'm wrong, but from what I've read, FCP on Windows Server 2003 sp2 requires AULA with host utilities and DSM 3.4 with snapdrive 6.2 and later.  I can turn it off and reboot, but the installation of ntap's DSM says AULA is required.  Does that make sense?


Re: FCP and MPIO - from the top?

not sure if i mix up something but as far as i know win2k3 comes with support for multipathing plugins, but has no plugin itself, thus you need to install ontap dsm. win2k8 comes with both, support and a plugin, so you can choose to either install the netapp plugin or the microsoft one.

as for win2k3, i always go for multipathing, THEN install host utils, then snapdrive. so maybe you should try a repair install of your host utils as they check for mpio install and set certain timeouts.

Re: FCP and MPIO - from the top?


     That is what i read as well.  The only MPIO for 2k3 that MS has is for iSCSI.  You need 3rd party for FCP.

     I'll try the host util repair and check back.  Thanks again.


Re: FCP and MPIO - from the top?

FYI I tried removing AULA on the igroups and rebooted the host.  Still nothing.

Do I need to do anything in the Emulex utilities?

Re: FCP and MPIO - from the top?

what fcp mode are you using? you should have system single image. multipath driver cannot differentiate between active and passive path as all are set to unoptimized (your screenshot).

Re: FCP and MPIO - from the top?

Both heads are single_image.  I tried repairing Host Utilities and nothing.

Is there anything funny re: FCP w/a 270?  Could that be an issue?