Data Backup and Recovery Discussions

HANA Plugin

ANDREAS_JANKOWIAK

Hi Community,

 

I've a problem by configuring the HANA plugin in SC 4.1.1. I've setup the plugin and I'm able to quiese the HANA database. When the database is quiesed a HANA Snapshot is created and shown in the backup catalog as a snapshot like backup.  When I unquiese the database the HANA snapshot is deleted.

When I try to perform a backup via SC the database is quiesed, the HANA snapshot is created (listed in Backup catalog), the storage snapshot is created and the database is unquiesed.

Unfortunately the backup entry in the backup catalog disappears when the backup is finished (successfully).

Did I miss something?

 

Thank you.

Best Regards,

Andreas

1 ACCEPTED SOLUTION

The user that created the key and the user that is running SC Agent should be the same.

 

Kapil

View solution in original post

23 REPLIES 23

ANDREAS_JANKOWIAK

Hi,

 

it seams the HANA plugin is not confirming the storage snapshot in the backup catalog. 

Therefore after deleting the HANA snapshot via "BACKUP DATA DROP SNAPSHOT" the snapshot is gone but also the information in the backup catalog.

Did I miss something?

 

Best Regards,

Andreas

Anyone?

Thanks

BR,

Andreas

 

Hi Andreas,

 

Could you please share SnapCreator Agent and Server logs for study?

 

Regards,

Saravana

Hi Saravana,

 

thanks for your reply.

Of course I can... is it possible to sent the logs directly to you via email?

 

Best Regards,

Andreas

 

Hi Andreas,

HANA plug-in will also do cleanup of snapshots from the HANA Backup Catalog as per the Snapshot retention policy set in the Snap Creator config.

If you retain daily 1 snapshot, old backup catalog entries will be deleted when the snapshot is cleaned up as part of retention.

 

The exisiting snapshots on NetApp storage should in any case exist in the backup catalog if they were created through the HANA plug-in.

 

Saravana will help you further with this issue. Once he receives the logs and config he will be able to debug the issue for you.

Thanks,

Kapil

 Hi Kapil,

 

thanks for your reply.

I've a retention of five snapshots and I get the problem even if there is no snapshot on the volume. 

 

The situation is: 

- HANA snapshot is created, checked via select * from m_snapshots

- I can see an entry in the backup catalog

- Storage Snapshot is created

- HANA snaphot is deleted,  but then the entry in the backup catalog dissapears

- Storage Snapshot is available 

 

Thanks,

BR,

Andreas

Hi Andreas,

What is your version of HANA DB?

Kapil

Hi Kapil,

 

1.00.097.00 but I've the same problem with another system which is on level 1.00.091.00.

 

I've sent the config and logs to Saravana.

 

Thanks!

Best Regads,

Andreas

Hi Andreas,

 

Is your SAP HANA SP7 and beyond? 

 

SAP-HANA catalog is maintained only for SP7 and beyond.

 

Following is the excerpt from logs specific to UnQuiesce operation (part of Backup)

The following highlighted statement is only executed if SAP SP6 or below is installed.

 

[2015-06-24 09:39:52,298] INFO: Application Unquiesce for plugin: hana
[2015-06-24 09:40:02,554] INFO: [vmsaplnx21:9090 (4.1.1.1)] (Wed Jun 24 07:39:55 2015) Database unquiesce started.
[2015-06-24 09:40:02,555] INFO: [vmsaplnx21:9090 (4.1.1.1)] (Wed Jun 24 07:39:55 2015) Deleting HANA database snapshot for [TST].
[2015-06-24 09:40:02,555] INFO: [vmsaplnx21:9090 (4.1.1.1)] (Wed Jun 24 07:39:55 2015) Attemting to run [backup data drop snapshot] on [vmsaplnx21].
[2015-06-24 09:40:02,555] DEBUG: [vmsaplnx21:9090 (4.1.1.1)] (Wed Jun 24 07:39:55 2015) Executing SQL sequence:
[2015-06-24 09:40:02,555] DEBUG: [vmsaplnx21:9090 (4.1.1.1)] (Wed Jun 24 07:39:55 2015) backup data drop snapshot
[2015-06-24 09:40:02,555] DEBUG: [vmsaplnx21:9090 (4.1.1.1)] (Wed Jun 24 07:39:59 2015) Command [su - tstadm -c "/hana/shared/TST/hdbclient/hdbsql -i 10 -n vmsaplnx21 -u SCADMIN -p xxxxxxxx -I /tmp/JSEsmYiXh4.sc"] finished with
[2015-06-24 09:40:02,555] DEBUG: [vmsaplnx21:9090 (4.1.1.1)] (Wed Jun 24 07:39:59 2015) exit code: [0]
[2015-06-24 09:40:02,555] DEBUG: [vmsaplnx21:9090 (4.1.1.1)] (Wed Jun 24 07:39:59 2015) stdout: []
[2015-06-24 09:40:02,555] DEBUG: [vmsaplnx21:9090 (4.1.1.1)] (Wed Jun 24 07:39:59 2015) stderr: []

 

Thanks and Regards,

Saravana

Hello,

 
this is strange... HANA is on level 1.00.097.00 but I've the same problem with another system which is on level 1.00.091.00.
 
BR,
Andreas

Hi Andreas,

 

I just checked the SAP website and the latest HANA release is SAP HANA DB 1.00.96 (SPS 09)

I am not very sure if you have a SPS 9 system.

Is this SPS0?

 

Kapil

 

 

Hi,

 

the latest patch is:

 

IMDB_SERVER100_97_0-10009569.SAR Revision 97 (SPS9) for HANA DB 1.00    from 18.06.2015

 

BR,

Andreas 

Hi Andreas,

 

My bad. You are using SnapCreator 4.1P1. 

 

You need to upgrade atleast to 4.1.1 to use catalog feature of HANA.

 

Thanks and Regards,

Saravana

Hi Saravana,

 

thanks! Oh my fault, SC Server is running with 4.1.1 but agent with 4.1 P1. 

I've update now the agent to 4.1.1, but now I get another error:

 

[2015-06-24 13:25:15,556] INFO: Application Quiesce for plugin : hana
[2015-06-24 13:25:20,790] INFO: [:9090 (4.1.1.1)] HANA application quiesce operation started.
[2015-06-24 13:25:20,790] ERROR: [:9090 (4.1.1.1)] * -10104: Invalid value for KEY (SCADMIN)
[2015-06-24 13:25:20,790] ERROR: [:9090 (4.1.1.1)] [hdb-00008] Running command on HANA node failed.[userstore key: SCADMIN, sid: TST]
[2015-06-24 13:25:20,790] ERROR: [1:9090(4.1.1.1)] SCF-00037: Application quiesce for plug-in [hana] failed with error [] and exit code [1], Exiting!
[2015-06-24 13:25:20,792] DEBUG: Workflow : quiesce_OnFailure started with workflow id : 194

 

 

The Key SCADMIN is valid.

Do you have an idea?

 

BR,

Andreas

 

The user that created the key and the user that is running SC Agent should be the same.

 

Kapil

View solution in original post

Hello,

 

now it is working ;o)) 

After creating the Key with user root like stated in the HANA plugin documentation "The userstore key is configured with the OS root user"...   it runs very well.

 

Test restore was successfull 😉 

 

Thanks again for your help!

 

Best Regards,

Andreas

Hello,

 

one further question: Is it ok to use nameing convention "recent" for snapshots when using the SAP HANA plugin? 

If yes I think I found a bug. 

 

BR,

Andreas

 

 

Hi Andreas,

No it is is not supported. This is documented in the Admin guide.

It is not possible to add this functionality as once backup catalog entry is created we cannot change the external backup ID/Comment.

Hence changing snapshot names won't work.

Once that functionality is available in HANA catalog we can consider supporting recent snaps.

 

We have a bug open to disable the option in GUI.

Regards,

Kapil

Hi Kapil,

 

wow this was fast ;o))   thanks!

I should read the admin guide deeper ;O)

 

Backup and restore works fantastic... HANA and NetApp is a cool combination.

 

Best Regards,

Andreas

 

Hi Andreas,

 

Are you able to connect successfully via hdbsql using this key? 

 

Also, it is good chech with newly created key (SnapCreator config also to be updated accordingly).

 

Let us know.

 

Regards,

Saravana

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public