Data Backup and Recovery Discussions

Highlighted

Netapp Data Broker 1.0.1 - prescripts and postscripts not working

Hi,

 

I'm trying to use the prescript and postscript option provided by the SnapCenter Plugin for VMware vSphere.

 

As described in the "Data Protection Guide for VMs, Datastores, and VMDKs using the SnapCenter Plug-in for VMware vSphere" on page 28, a perl script can be placed on the Netapp Data Broker Appliance. This script can be specified in the backup policy.

 

This works fine,  script is executed BUT

 

When I look at the environment variables that are available during prescript and postscript I see this:

prescript:

BACKUP_PHASE=PRE_BACKUP

 

postscript:

BACKUP_PHASE=PRE_BACKUP

 

During the Prescript and Postscript phase I see the same value for variable "Backup_Phase". For the postscript this is not correct.

Also the other environment variables mentioned on page 29 are not available.

 

Question: Can someone confirm if this is a know issue and/or this is going to be fixed ?

 

 

4 REPLIES 4
Highlighted

Re: Netapp Data Broker 1.0.1 - prescripts and postscripts not working

I have an update on this issue:

 

Netapp has recognised this as a bug. there are 2 bug ID's (duplicate) 1284616 and 1275798.

This issue is scheduled to be fixed in the next release of Netapp Data Broker.

 

Greetings,

Kris Boeckx

Highlighted

Re: Netapp Data Broker 1.0.1 - prescripts and postscripts not working

Any ETA on a fix for this? Is it sorted in the 1.0.1d patch?

Highlighted

Re: Netapp Data Broker 1.0.1 - prescripts and postscripts not working

Are there any notes with this patch ?

Where do I find this patch so I can have a look ?

Highlighted

Re: Netapp Data Broker 1.0.1 - prescripts and postscripts not working

I'm afraid the D1 patch doesnt have any fixes for the environmental variables. These are to be fixed in D2 which is due soon, also in 1.1 which is due a bit later.


D2 will be available on this URL https://mysupport.netapp.com/products/netapp_databroker/1.0.1D2/index.html

D1 is available now on this URL https://mysupport.netapp.com/products/netapp_databroker/1.0.1D1/index.html

Try the NEW Knowledgebase!
NetApp KB Site
Forums