Data Backup and Recovery Discussions

Problem pushing out SnapCenter


I had an issue with backups suddenly failing stating that a job was already running, even though it had cancelled.

I removed the plugins and the Host and then tried to redeploy, but it keeps failing. The error in the install log is:


9-21-2020[01:02:13 PM]: (CLR Action): SWInstallerHelper: Begin CheckStaleServiceExist.
9-21-2020[01:02:13 PM]: Engine: property 'IS_STALE_SERVICE_EXIST' value now 'true'
9-21-2020[01:02:13 PM]: (CLR Action): SWInstallerHelper: CheckStaleServiceExist: SCWPluginService is exist, remove the service manually & re-try the installtion again
9-21-2020[01:02:13 PM]: Action returned value 0x00000643
9-21-2020[01:02:13 PM]: Action 'CheckStaleServiceExist' returned status 0x80070643
9-21-2020[01:02:13 PM]: Original exit status: 0x80070643, final exit status: 0x00000643

I have checked the registry for any stale NetApp registry keys and cannot find any. I have checked the "Program Files" folder and there is nothing there. Where else could the installer be looking when performing this 'CheckStaleServiceExist' routine?


Re: Problem pushing out SnapCenter




Have you tried rebooting the server and re-try the operation? if not please perform a reboot and try again.

If reboot was already performed, please follow the kb below on how to remove stale entry for snapcenter plugin:





View solution in original post

Re: Problem pushing out SnapCenter


Thanks for the response and the link. The SnapCenter server was rebooted at the weekend for patching. The host server which I am trying to add is due for a reboot next Monday, as it is a clinical system, and we must plan downtime. I have checked and it is in a pending reboot state at the moment. Hopefully, this is what is causing the failed installs.

Re: Problem pushing out SnapCenter


All sorted now. Thanks again.

"sc delete SCWPluginService" was the command which cleaned up the last bit of the plugin.

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums