Data Backup and Recovery Discussions

Problem with Global Config on SnapCreator 4.0p1


Hi, I've a question on Global configuration. I'm migrating our old 3.5 environment one configuration at a time and I've a little problem with something related to global configuration.

I have a global.config in the root config folder with some globally defined parameters and then I've local global.conf configuration  under the profile folders to change options and define locally needed parameters.

Now I have a backup/snapshot done on some vfilers that is not working because I've in the root global.conf  the options:




I've put the same options with N in the local profile global.conf:



but when I run the backup I get the error that consistency group are not supported on vfiler (but I've disabled it on the local global.conf).

I've tried to put the same option on the itromfsv02.conf file but it seems that the snapconfig continue to get the root global configuration ones.

Is this normal?

How are option loaded/used?

If I do the reverse (define "N" in the root global.conf and "Y" in the global.conf or itromfsv02.conf configuration file) it seems to work correctly (and report the error).

This is the error (just to document it as it's not the error that is important but the problem on how the options seems to load from local/global configuration files).

########## Starting Consistency Group Snapshot copy for all controllers ##########

[Wed Oct 2 17:43:40 2013] INFO: Starting Consistency Group Snapshot copy for vfiler_ITROMFSV02

[Wed Oct  2 17:43:44 2013] INFO: STORAGE-02001: Creating consistency group Snapshot copy [BCK-hourly_20131002174339] on volumes [[p_home, n_home, v_home, vfroot_ITROMFSV02]].

[Wed Oct  2 17:43:44 2013] ERROR: netapp.manage.NaAPIFailedException: API not supported. (errno=13012)




    at com.netapp.snapcreator.workflow.task.CGSnapshotTask.execute(



    at java.util.concurrent.FutureTask$Sync.innerRun(


    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(

    at java.util.concurrent.ThreadPoolExecutor$


Caused by: netapp.manage.NaAPIFailedException: API not supported. (errno=13012)

    at netapp.manage.NaServer.invokeElem(


    ... 10 more

[Wed Oct  2 17:43:44 2013] ERROR: STORAGE-02003: Creating consistency group Snapshot copy [BCK-hourly_20131002174339] on volumes [[p_home, n_home, v_home, vfroot_ITROMFSV02]] failed with error [netapp.manage.NaAPIFailedException: API not supported. (errno=13012)];

[Wed Oct 2 17:43:40 2013] ERROR: Consistency Group Snapshot copy for vfiler_ITROMFSV02 volumes[p_home, n_home, v_home, vfroot_ITROMFSV02] failed exiting !

[Wed Oct  2 17:43:44 2013] ERROR: Task: cgsnapshot with config:FS_Share@itromfsv02 failed



Hello Francesco,

config file >> Profile Global >> Super Global

Profile Global overrides Super Global

config file overrides Profile Global

Anything in your config file is final

If you want a key value to be supplied by the profile or super gloabl file, put them only in the appropriate place and don't mention anything in the config file.

The values are controlled by USE_GLOBAL_CONFIG in the config file.

What is the value of USE_GLOBAL_CONFIG in your itromfsv02.conf?

As a easy test you may try with these.





On that configuration USE_GLOBAL_CONFIG=Y.

So it seems something that is working bad at some level.

I've all the default options on Super Global (included all the storage password and so on). All things that need to be changed from the default and valid for the entire profile (for example for all the Oracle dev server or for all virtual machine) is configured into the local Profile Global and then I have only volume/backup information in each single profile.conf file.

I cannot test with USE_GLOBAL_CONFIG=N because SC will not get configuration.

It seems that the parameter in the profile global or config file for this parameter is completely ignored.


Francesco, we're having similar issue with "Super Global" config file being ignored. It affects GUI operations only, however. Same tasks done via CLI work correctly.

How is it in your case? Do you use GUI or CLI?


Lukas Kubin


There should be no difference between CLI and GUI there is the USE_GLOBAL_CONFIG option. If this is set to Y it means when a workflow is triggered SC will read Super global, then profile global (anything set in both will be overwritten by profile global), and finally the local config (anything set in local config will override profile and super global). From this point we have all parameters and execute a workflow.

I will look into this issue and see if I can reproduce something




Thanks Keith, that would be great. I've created a similar post earlier today:

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner