Data Backup and Recovery Discussions

Problems with Snapcreator 3.3 Windows Service

I am trying to setup a Windows service for our new install of 3.3.  The Server is running on Windows 2008 R2.  I followed the instructions from the Installation and Administration guide and was able to setup a service.  When I try to start the service, it starts OK and I can browse to the web page.  However when I try to login, I get the error:

"Unknown failure, check service logs for more details"

However I am not able to find the logs anyways.  I have looked in event viewer, in the Snap Creator server directory, all with no luck.  Can anyone point me to these logs?  When I start the service up manually and not through a Windows service the GUI console works with no issue.

I have installed java 1.6.0-24 and have tried using both the jdk and jre binaries.

The more details section of the logs shows:


2011-03-30 10:30:15,346

Unknown failure. Check service logs for more details.

No details are availble.

No suggested corrective action is available.

Location is not specified.

App Name: Netscape
App Version: 5.0 (Windows; en-US)
App Codename: Mozilla
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20110319 Firefox/3.6.16 ( .NET CLR 3.5.30729)
Platform: Win32
Cookie Enabled: true


Re: Problems with Snapcreator 3.3 Windows Service

This is a known issue w/2008 and using this method to create service does not work. If you figure out how to get service working on 2008 please post.  Workaround is to use task scheduler and start GUI when system starts  In the next release we are working on creating a legit service, just not there quite yet  Regards,  Keith

Re: Problems with Snapcreator 3.3 Windows Service

Thanks Keith.  I have been trying to do this without much luck.

I created a task with Action: "Start a program"

Trigger: At system startup

Program / script: "C:\Program Files\Java\jdk1.6.0_24\bin\java.exe"

Add arguements: -jar C:\NetApp\Snap_Creator_3.3.0\scServer3.3.0\gui\snapcreator.jar

Run as user: LOCAL SERVICE

The task appears to start and complete, but the process is not running and the service is not up.  Can anyone think of any obvious items I am missing on the task setup?

The history plays out like this:

Task Scheduler started "{f060aa39-cc3e-430c-a121-774cbef11bd3}" instance of the "\SnapCreator GUI Start" task for user "NT AUTHORITY\LOCAL SERVICE".

Task Scheduler launched action ""C:\Program Files\Java\jdk1.6.0_24\bin\java.exe"" in instance "{f060aa39-cc3e-430c-a121-774cbef11bd3}" of task "\SnapCreator GUI Start".

Task Scheduler launch task "\SnapCreator GUI Start" , instance "C:\Program Files\Java\jdk1.6.0_24\bin\java.exe"  with process ID 2824.

Task Scheduler successfully completed task "\SnapCreator GUI Start" , instance "{f060aa39-cc3e-430c-a121-774cbef11bd3}" , action "C:\Program Files\Java\jdk1.6.0_24\bin\java.exe" with return code 4294967295.

Task Scheduler successfully finished "{f060aa39-cc3e-430c-a121-774cbef11bd3}" instance of the "\SnapCreator GUI Start" task for user "NT AUTHORITY\LOCAL SERVICE".

Re: Problems with Snapcreator 3.3 Windows Service

Try adding the java call to run snapcreator.jar in .bat file. Test .bat file make sure gui starts if so add .bat file as task and test. I have seen issues where windows task manager cant handle certain arguments.  Let me know if this works  Keith

View solution in original post

Re: Problems with Snapcreator 3.3 Windows Service

This worked great.  Thanks for the help.

Cloud Volumes ONTAP
Review Banner
All Community Forums