Data Backup and Recovery Discussions

SDCLI. Unable to create LUN (iSCSI RDM)


Hi. Using Snapdrive from GUI and passing it the same parameters of the command line works. No change to have it using sdcli

My command is:

sdcli disk create -d D -p filer:/vol/volname/lunname.lun -z 491520MB -IG vmwaresrv01 rcu_generated -dtype dedicated -ds DSP_ROM10

I get the error (EX01 is the server from where I execute SDCLI):

EX01 : Checking input parameters

EX01 : Checking access control

EX01 : Checking policies

Unable to create LUNs.

Error: No igroup found for the current node.

DSP_ROM10 is the iSCSI datastore where to put the rdm file, rcu_generated is the igroup name containing all the iqn of the vmware esx forming the cluster and vmwaresrv01 is the vmware esx server hosting EX01 vm.

I've also tried to put between " the DSP_ROM10 datastore name

Any idea? Help?


Re: SDCLI. Unable to create LUN (iSCSI RDM)


what is the snapdrive version you are using?

Re: SDCLI. Unable to create LUN (iSCSI RDM)


6.5 64bit on Windows 2008 R2

Re: SDCLI. Unable to create LUN (iSCSI RDM)


can you please post the output for sdcli igroup list -m "hostname" -f "filer ipaddress"

Re: SDCLI. Unable to create LUN (iSCSI RDM)


Already tried. It's correct. In my opening post I've changed some name for privacy reasons...anyway the REAL command is

sdcli disk create -d D -p itromfs10:/vol/rom_exchange_ex01_users_data/rom_exchange_ex01_users_data.lun -z 491520MB -IG itromvm12 rcu_generated -dtype dedicated -ds DSP_ROM10

I've a doubt. Should I put the iqn and not the host name? Manuals seems to say "hostname" and not iqn

C:\Program Files\NetApp\SnapDrive>sdcli igroup list -f itromfs10

Listing the Initiator groups ...

   Node Name: ITROMEX01

Initiators Group Name: rcu_generated

Initiators Group Type: ISCSI




















The operation completed successfully.

Re: SDCLI. Unable to create LUN (iSCSI RDM)


MANUAL BRINGS ON THE WRONG PATH putting vmwsomething in the sample as name

In the IG parameter the pair is formed by the host name where's the LUN is creating and the igroup that contains the ESX iqn

    C:\Program Files\NetApp\SnapDrive>sdcli disk create -d D -p itromfs10:/vol/testtest.lun -z 2048MB -IG itromex01 rcu_generated -dtype dedicated -ds DSP_ROM10

ITROMEX01 : Checking input parameters

ITROMEX01 : Checking access control

ITROMEX01 : Checking policies

ITROMEX01 : Turning off snap scheduling

ITROMEX01 : Creating the LUN

ITROMEX01 : Creating a partition

ITROMEX01 : Formatting the disk with NTFS

ITROMEX01 : Mounting volume on the disk

UNC Path: None

LUN Path: itromfs10:/vol/test/test.lun

        Storage System:         itromfs10

        Storage System Path:    /vol/test/test.lun

        Type:                   lun

        Disk serial number:     7SEaX+C0LbkS

Backed by Snapshot Copy:

        Shared:                 No

        BootOrSystem Disk:      No

        SCSI port:              2

        Bus:                    0

        Target:                 2

        LUN:                    0

        Readonly:               No

        Size:                   2055

        Snapmirror Source:      No

        Snapvault Primary:      No

        Disk Partition Style:   GUID Partition Table (GPT)

        Clone Split Restore status: Normal

        DiskID:                 2

        Volume Name:            \\?\Volume{5b622f97-1f47-4645-bf5d-ac599af3062b}


        DataStore Name:         DSP_ROM10

        RDM File Name:          [DSP_ROM10] ITROMEX01/ITROMEX01_SD_itromfs10_7SE


        Mount points:           D:\

        IP Addresses: ,,, 10.205.

4.10,,,,,, 10.20


The operation completed successfully.

C:\Program Files\NetApp\SnapDrive>

View solution in original post

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums