Data Backup and Recovery Discussions

SME using wrong DC?

mrphoenix

Hi folks,

I'm trying to setup SME for my new Exchange 2010-Server and running in following error during the final steps of the Configuration Wizard:

The Configuration Wizard failes at "Task 14: Completing SnapManager configuration". The Configuration Report states this:
     Unable to query autosupport settings.
     Failed to send autosupport message.
     Failed to configure Exchange for SnapManager.
     The LUN may not be connected, because its mount point cannot be found.

A little above the error is raised by a powershell-command that uses a wrong DC so the question is, how can I tell SME to use a different DC when executing those PowerShell-Commands?

[PowerShell Cmdlet Error]: Received a referral to magna.global when requesting CN=SystemMailbox{50156b04-b14e-4fd2-96e7-332b68aa85f4},CN=Microsoft Exchange System Objects,DC=magna,DC=global from framsroot01.root.global.  You have specified the wrong server for this operation.
Failed to mount the database.
[PowerShell Cmdlet Error]: Received a referral to magna.global when requesting CN=SystemMailbox{50156b04-b14e-4fd2-96e7-332b68aa85f4},CN=Microsoft Exchange System Objects,DC=magna,DC=global from framsroot01.root.global.  You have specified the wrong server for this operation.
[PowerShell Cmdlet Error]: Received a referral to magna.global when requesting CN=SystemMailbox{50156b04-b14e-4fd2-96e7-332b68aa85f4},CN=Microsoft Exchange System Objects,DC=magna,DC=global from framsroot01.root.global.  You have specified the wrong server for this operation.

Hope anybody can help me out with this?

Greetings,

Philipp

14 REPLIES 14

Re: SME using wrong DC?

lwei

Philipp,

Do you know which cmdlet had error? If you do, you can try it out separately to debug the issue.

Regards,

Wei

Re: SME using wrong DC?

mrphoenix

Hi Wei,

Thanks for you reply.


The mount-DB-Command get's wrong because it uses the wrong DC.

The error message is:

[PowerShell Cmdlet Error]: Received a  referral to magna.global when requesting  CN=SystemMailbox{50156b04-b14e-4fd2-96e7-332b68aa85f4},CN=Microsoft  Exchange System Objects,DC=magna,DC=global from  framsroot01.root.global.  You have specified the wrong server for this  operation.

Failed to mount the database.

[PowerShell Cmdlet  Error]: Received a referral to magna.global when requesting  CN=SystemMailbox{50156b04-b14e-4fd2-96e7-332b68aa85f4},CN=Microsoft  Exchange System Objects,DC=magna,DC=global from  framsroot01.root.global.  You have specified the wrong server for this  operation.

[PowerShell Cmdlet Error]: Received a referral to  magna.global when requesting  CN=SystemMailbox{50156b04-b14e-4fd2-96e7-332b68aa85f4},CN=Microsoft  Exchange System Objects,DC=magna,DC=global from  framsroot01.root.global.  You have specified the wrong server for this  operation

Basically I need to change the DomainController-Parameter that is beeing parsed to the exchange from SME.

Best regards,

Philipp

Re: SME using wrong DC?

qzhang

There is no way to specify a different DC for running a cmdlet from SME. SME is using "CurrentConfigDomainController" setting retrieved from cmdlet "get-exchangeserver -status -identity " for all other powershell operations. If you run get-exchangeserver -status, the "CurrentConfigDomainController" is the one used in the cmdlet, you may want to try to use "Set-AdServerSettings" cmdlet to set to the right DC.

Thanks,

-Qing

Re: SME using wrong DC?

mrphoenix

Hi folks,

After some really though investigations altogether with MS-Support I've discovered a permission problem within the "default domain Controllers policy"

I corrected this and now I'm able to configure the SME App perfectly.

Well ... now I'm having another problem - when I try to backup a datastore I can't select it via the GUI 'cause all of them are greyed out There's a red exclamation mark on the icon and the path to the storage group is marked as invalid.
btw.: I'm using mountpoints instead of driveletters for my storage-groups. (e.g.: c:\mxstore\mec-eu01\db - the "db" is a mountpoint to a dedicated LUN of my netapp-system).

Hope anybody has an idea about that?

Greetings,

Philipp

Re: SME using wrong DC?

qzhang

It is db layout issue. You can simply re-run the config wizard, specify the same mount point to a Db as you intend to do (sometime that means same mount point as source and target), the config wizard will correct the problem, i.e., it may need to dismount the db to rearrange the path.

Thanks,

-Qing

Re: SME using wrong DC?

lwei

Hi Philipp,

Can you assign a drive letter to the DB LUN and try again? The mount point should work but nested mount point may not.

Regards,

Wei

Re: SME using wrong DC?

mrphoenix

I'm seeing the DB-paths double within SME and did a reconfig about 4 or 5 times today without success 😉
I assume the reason why I'm seeing the stores double is because I have to NICs in that server. I've configured the iSCSI-Initiator to use only one IP but I can still see two sessions. One with the Source-IP 0.0.0.0 and the second with the correct IP that was configured.

Re: SME using wrong DC?

lwei

Looks like you need to clean up your iSCSI configuration. The session with 0.0.0.0 IP is invalid.   -Wei

Re: SME using wrong DC?

mrphoenix

how should I do that?

Before configuring SME I've configured the iSCSI-Connection with Snapdrive 6.0.2 BECAUSE you shouldn't do this via the iSCSI Initiator from MS on a Windows 2008 R2 box anymore 😞
So how to get rid of this connection?

Stopping Exchange, deleting the iSCSI-Connection and starting Exchange doesn't help. It connects the session automatically at least after a reboot ...

Re: SME using wrong DC?

mrphoenix

Hi!

Changing to dedicated Driveletters fixed the issue, but what if I don't like this?


How should I handle driveletters for 30+ DBs on one Exchange(-Cluster) if I would like to have dediated LUNs for each DB because of fault-tolerance and load-balancing?

What do I have to change at the mount points to get SME up and running?

Currently I'm using

c:\mxstore\db-name\db (where "db" is the mount point)

c:\mxstore\db-name\log (where "log" is the mount point)

Would changing to

c:\mxstore\db1 (where "db1" is the mount point)

c:\mxstore\log1 (where "log1" is the mount point)


help?

Best regards,

Philipp

Re: SME using wrong DC?

lwei

Yeah, you need to use mount points. I think what you said should work. But if not, try:

c:\mxstore_db1 (where "db1" is the mount point)

c:\mxstore_log1 (where "log1" is the mount point)

Thanks,

Wei

Re: SME using wrong DC?

lwei

Why you can't use iSCSI Initiator tool? I use it all the time. At least, can't you use it to do clean up? Thanks,   -Wei

Re: SME using wrong DC?

mrphoenix

Hi!

It works with c:\mxstore\dbname_db\ (where "dbamen_db" is the mountpoint)

Thanks for the help!

have a nice weekend,

Philipp

Re: SME using wrong DC?

mrphoenix

Sure i can, but it's not recommended by Netapp - at least that I have been told 😉

For any changes on iSCSI please use the SnapDrive-Utility

I'm currently reconfiguring my mountpoints which takes some time. And to be honest I don't care over how much paths my server sees the netapp as long as there is at least one 🙂

Philipp

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums
Public