Data Backup and Recovery Discussions

SMO Support for RedHat Enterprise Linux 6 using ASM

PYTHONMEISTER

Hi,

we are heading to set up a new Oracle database cluster.

The components in question are:

  • RedHat Enterprise Linux 6, preferably 6.4, alternatively Oracle Unbreakable Linux 6.4
  • SnapManager for Oracle 3.3
  • Oracle Database 11gR2 (11.2.0.3+)
  • SnapDrive for UNIX (Linux)
  • NetApp Metrocluster on OnTAP 8.1

The setup should be a Oracle RAC cluster on two HP DL380gen8 servers using ASM.

As far as I know, Oracle ASM is supported under RedHat EL 6.4 as of 07/22/2013, and it is needed for SMO to work (which I don't understand).

The question is:

Is the combination above supported ?

9 REPLIES 9

SHEETZDBA

I don't believe Snap Manager for Oracle requires ASM.

The problem used to be that asmlib wasn't supported, and didn't function, on RHEL 6. Snap Manager for Oracle has to have asmlib to work, if you use ASM.

Looking at the support matrix, Redhat 6.4, SnapManager 3.3, FC, and Oracle 11.2.0.3 are compatible.

That said, you want to be 100% certain your intended configuration is supported and tested before you start. Getting this all to function for us wasn't what I'd call easy.

darkavich

SDU 5.2 doesn't work under RHEL 6.4.

The support matrix is wrong. It's not just a Netapp issue. None of the other storage vendors have tools that work with 6.4.

ashwath

Hi Stefan,

      One quick clarification on Data ONTAP. Is it 8.1 7-mode or 8.1 Clustered ONTAP?

Thanks,

Ashwath

PYTHONMEISTER

I forgot to say:

The storage connection is via FC not NFS.

ashwath

Hi Stefan,

      The above configuration is supported. However, SMO/SDU is not qualified/tested on Metrocluster.

Thanks,

Ashwath

PYTHONMEISTER

A NetApp engineer told us this configuration can't be built,

it won't work, as there are technical issues.

Could you please clarify this ?

ashwath

Do you mean the part of this config is not supported or the entire config itself is unsupported?

Thanks,

Ashwath

PYTHONMEISTER

He said that the installation of SnapManager for Oracle under RedHat 6.4 could not be installed.

And (if one could install) it would not be possible to create snapshots.

PYTHONMEISTER

It is 8.1 7-mode.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public