I had this issue when doing the same migration, it seems to be a registry writing issue and I solved it thus:
The confusing thing is I was able to migrate the SQL Reporting Services AND the SQL TempDB first time no problem, but it choked on the MSDB, MASTER and MODEL databases, which confused things as TEMPDB is a system database too so I could not see why it did some and not others. The wonderful world of MS security I suppose.
Anyway per the KB article as above (NetApp KB article ID 2016403) I added the service account that I use to run the SQL Server service and the SQL Server Agent service to the local admins group on the server, ran up REGEDT32 on the server(2008R2) and gave that account full control at the HKEY/LocaMachine level … rebooted and tried again, and it all worked. Just restarting the services didn't help.
After that you can remove the extra registry perms I suppose, it just needs them to write the changes it makes when it moves the DB’s …
Hope this helps someone ! Worked for me anyway after much irritation ...
Here is the text of the KB, just for reference. Note that my fix didn't work until a full reboot by the way, not mentioned here.
KB:
Symptoms
When using SnapManager for Microsoft SQL Server (SMSQL) to migrate SQL system
databases (master, model, msdb) to NetApp LUNs, the configuration wizard fails
with the following error code:
Configuration operation failed.
Details: [SQL-DMO API Error]:
Source: Microsoft SQL-DMO (ODBC SQL State: 42000)
Error Message: IDispatch
error #21490
Description: RegCreateKeyEx() returned error 5, 'Access is
denied.'
Click here for a snapshot of the error message.
There are no corresponding events in the event viewer to help determine the
cause.
Cause
- The SQL server was configured with the least privilege. The SQL Server
(instance) service is configured to use a domain user account, instead of using
the Local System account. Also, the domain user account is not a member of the
local administrators group.
Solution
Perform the following steps to resolve the issue:Cause 1:- Add the SMSQL service account user to the local administrators group.
- Restart the SMSQL service.
Cause 2:- Add the SQL Server
(instance) service account user to the local administrators group. - Restart the SQL Server (instance) service.
- Once the SQL system databases are migrated to NetApp LUNs, the SQL Server
(instance) service account can be removed from the local administrators group.
Any scheduled job to backup these databases continues; however, a full
regression testing is not performed and some integration features with other
products might not function as expected.