Data Backup and Recovery Discussions

SMSQL and Data Protection Integration Not Working

I have 3 2008 R2 VM's using SMSQL v 5.1 and SnapDrive v 6.3 configured with DFM. 1 of these servers has 2 LUNs, 1 for SQL Data/Logs, the other for SnapInfo. The other 2 servers have 3 LUNs, 1 for SQL Data/Logs, 1 for TempDB and the other for SnapInfo. Each LUN has been created out of qtree's and not volumes. Regardless of the configuration the problem is the same.

When I run the "Configuration Wizard" for each database server it goes through the many different screens and it's able to detect Protection Manager, I select the databases to protect and select the protection policy of "Remote backups only" (I have tried a custom made policy as well with no avail) and continue following the wizard to completion. It creates the dataset relationship and I manually assign a resource pool to it, everything looks good up until this point. I then run the "Backup Wizard" but when I get past the "Verification Settings" all my options are grayed out including the desired one "Archive backup to Secondary Storage*". Needless to say my datasets begin to throw out lag errors as SnapManager isn't working properly with Protection Manager, no backups are being SnapVaulted to secondary storage.

I have a very similar configuration but with SME and Exchange 2010 and that's working perfectly (qtree LUNs, Protection Manager integration).

What could I be missing? Why am I not able to select options regarding Backup archiving while running the Backup wizard in SnapManager?

Screenshots attached.


SMSQL and Data Protection Integration Not Working

Furthermore, if I run the "Protect now" (on demand protection) option the job runs successfully but with the following event "Could not find any backups to transfer on Primary data node of application dataset SnapMgr_SQLServer_XXXXXXXXXXXXX(817)."

Re: SMSQL and Data Protection Integration Not Working

The problem was with the fact that I had the system and user databases in the same qtree/lun - when i separated them and backed them up at different times the problem went away.

Review Banner
All Community Forums