Data Backup and Recovery Discussions

Highlighted

Single Mailbox Recovery 8.0.1 (SMBR) install on separate Server?

Hi... 

 

We currently have an "interesting" discussion with NetApp Support. Maybe the community would like to weigh in.

 

We've used SMBR with SME for years. Always had it installed on a separate machine with SnapDrive and Outlook on it. When a restore needed to be done we simply mounted a clone of the Mailbox DB LUN on the SMBR machine, mounted the DB in SMBR and so on. Worked like a charm.

 

Now we "upgraded" to SnapCenter and SMBR 8.0.1.

 

It looks really fancy -> https://youtu.be/9vnEtG5MTRQ

 

We assumed that it would be a similar workflow with SMBR on a separate machine, but NetApp Support now tells us that we need to install SMBR together with outlook on each and every Mailbox DB server. Outlook on an Exchange server is a big no no and no decent Exchange server admin in an enterprise environment will allow it.

 

We do not understand why this should be required. SMBR should be able to query the SnapCenter server for DBs in valid backups, the user then selects the DB and since SnapCenter knows on which LUN it's located, it can clone and mount it on the machine that's running SMBR. SMBR can then mount the EDB and restores can be done to PST or Echange Mailbox just as before.

 

Can somebody please confirm that this is not true? We're 100% certainly not going to install Outlook on our Mailbox DB Servers. Furthermore attaching LUN clones on a productive server goes against our change management policies and could only be done after hours, which is also unacceptable.

 

Thanks for any inputs!

5 REPLIES 5
Highlighted

Re: Single Mailbox Recovery 8.0.1 (SMBR) install on separate Server?

Was there any additional follow up on this support case? Did you find a workaround that didn't require installing Outlook on all of your Exchange servers?

Highlighted

Re: Single Mailbox Recovery 8.0.1 (SMBR) install on separate Server?

I have to say that it is true!

 

Single Mailbox Recovery (SMBR)  runs on the Exchange server on which Microsoft Outlook is running, and it uses native Microsoft Messaging Application Program Interface (MAPI) protocol to communicate with the Microsoft Exchange Server that is running on a separate machine. SMBR also requires for the SnapCenter Plug-ins package for Windows (SCW+SCE) to be installed on the Exchange server. The SMBR architecture requires that you have SMBR installed on the Exchange server.

 

SMBR passes a query to identify the host name for Exchange, hence the backup snapshots will only load on the active server

Highlighted

Re: Single Mailbox Recovery 8.0.1 (SMBR) install on separate Server?

Like a few others have indicated, this is definitely the guidance/requirements we've gotten back from NetApp.  Like you, we're definitely opposed to installing Office components on our MBX servers, so that's a no-go.  We're currently in the process of backing out SMBR 8 from our beta environment and we'll regroup in the future if/when this is resolved.

 

I would encourage you to reach out to your account team and let them know your dissatisfaction with this approach.  I've gotten some indications that the TMEs/etc are aware that this isn't flying well with customers, so I'm cautiously optimistic that Kroll and NetApp will come up with a "fix" to get it back the way it was (i.e. SMBR+Outlook on a dedicated server).

 

Hope that helps,

 

Chris

Highlighted

Re: Single Mailbox Recovery 8.0.1 (SMBR) install on separate Server?

I know this is an old case but I thought I'd comment in case someone like me comes along and wants updated info.

 

It appears that the product has been updated to allow it to once again be installed on a standalone server. You no longer are required to install SMBR directly on one of your PRD Exchange servers. 

 

Highlighted

Re: Single Mailbox Recovery 8.0.1 (SMBR) install on separate Server?

Where are instructions to install it on a separate server? Also I get the same error whether Outlook 2016 64-bit (Since you can't put the 32-bit one on Exch 2016 since it has the 64-bit Microsoft SQL Engine installed) and SMBR are on the Exchange server or on a Standalone server . So I don't know what I  may be missing. I've got the plugins for Windows and Exchange on both servers. The HW provider that is registered is the one for SnapCenter. 

 

The error is when authenticating  it fails with 

An error occurred: Command Open-SmConnection failed. Please contact a technical support representative.

If trying to connect from machine other then Exchange Server, please provide the Exchange Server name or address.

Check out the KB!
NetApp Insights To Action
All Community Forums