Data Backup and Recovery Discussions

Snap Creator 4.1.2 allowed commands

I am trying to get this in the allowed command file instead of having to put in an "*".


NTAP_SNAPSHOT_CREATE_CMD02="C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe" -Command Import-Module SnapDrive;Set-SdSnapshot -Snapshot %SNAME-%SNAP_TYPE_%SNAP_TIME -StorageSystem TEST -VolumeName TEST-SnapMirrorLabel Daily


The command completes just fine with "*"


I have tried "C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe" without quotes added -Command several things.


Any assistance would be greatly appreciated.


Re: SnapCreator 4.1.2 Allowed Commands file


Re: Snap Creator 4.1.2 allowed commands



Looking at the command, the entry in the allow_commands.config file should be:




You don't need to add anything after that.


Be sure that you restart the agent after making the changes.




Re: Snap Creator 4.1.2 allowed commands

That does not work.  I have already tried that.  I did restart the agent.