Data Backup and Recovery Discussions

Highlighted

SnapCenter 4.0 - SQL Databases not showing up

Hey,

 

I have just started evaluating SnapCenter and have already stumbled upon something I don't understand. However I think it's either a mis-use on my side or a "works as designed" that I don't understand rather than a bug.

 

So I have installed SnapCenter with a Dom Ad account for testing purposes, added a few hosts and an SQL Server. Setup was no problem, full- and log-backups are working fine. Now I went to take care of user management. What I did:

 

- Added an Active Directory Group to SnapCenterAdmin Role

- Users in Group can authenticate just fine but didn't see anyhting

- Of course, so under User Access - All I granted the permissions to every object for that group.

 

Now members of that group can see storage systems, hosts, policies and all that just fine.

 

However what does not show up are SQL databases (Resources - Databases). If I log in back as the DomAd I jused to set everything up, the databases are showing up just fine so I can do for example a restore.

 

However as one of the other AD users in the group, the databases do not show up. The instance appears and I can run a backup - but no restore, since for that I would require the database view.

 

What am I doing wrong?

Thanks guys Smiley Wink

Regards,

 

Chris

2 REPLIES 2

Re: SnapCenter 4.0 - SQL Databases not showing up

On Resources/Microsoft SQL Server/Database - if no, or not all databases are shown - use the "Refresh Resources" button.

After discovering, the databases are shown.

regards,

Dirk Giron.

Re: SnapCenter 4.0 - SQL Databases not showing up

Hi CHMOELLER,

 

Many changes have gone into RBAC feature over the releases in SnapCenter. Latest version available is 4.1.1

 

Can you please try adding the users which are the members of the AD group as SQL sysadmin users in your SQL host and then log in to SC and try discovery?

Forums