Subscribe
Highlighted

SnapCenter 4.0 vSphere Plugin with multiple VC's

I am having some problems with a new installation of SnapCenter 4.0 and the plugin intergration with VMware vSphere 6.5.

 

I have 2 vCenter servers in linked mode and deployed the SnapCenter plug-in for VMware vSphere to a server and intergrated it with vSphere at site A, when I have checked the web console everything looks correct & I am able to configure the resource groups, policies etc.

 

I have then deployed the SnapCenter plug-in for VMware vSphere to another server and intergrated it with vSphere at site B. I have reloaded the vSphere web client and checked the plug-in is working for site B again I can configure resource groups, policies etc.

 

However if I try and select the plug-in for Site A again if fails to connect and I get an error message "Internal Server Error" (see attached). If I reinstall plug-in at Site A it starts working again but then breaks Site B.

 

Has anyone else had this? What am I missing? The plugin has been installed on different servers for each site as per the SnapCenter documentation.

Re: SnapCenter 4.0 vSphere Plugin with multiple VC's

One quick question to get more detail around deployment. In your scenario are there two SnapCenter Servers involved here one for site A and one for site B or both VMWare plug-in instances

are communicating with same SnapCenter Server.

 

Two SnapCenter Servers are not supported in above scenario.

 

 

Re: SnapCenter 4.0 vSphere Plugin with multiple VC's

There is a single SnapCenter server & the plug-in has been installed on a server local to each site.

 

I have managed to resolve the issue by removing all the plug-ins, rebooting the vCenter servers reinstalling the plug-ins again and then another reboot of each vCenter server.

Re: SnapCenter 4.0 vSphere Plugin with multiple VC's

Very interested in this as we're about to do the same thing in the next few weeks. We have two linked mode vCenter servers as well.

 

My slightly different issue is that I need to keep VSC running on one of the vCenter servers (it points to our older 7-mode systems that can't use SnapCenter) and run the SnapCenter plug-in on the other vCenter server which points to our cdot resources. Do either of you know if this configuration is supported?

Re: SnapCenter 4.0 vSphere Plugin with multiple VC's

Thanks for update Rapp

 

Linked mode vCenters communicating with same SnapCenter server is supported model.

 

Whenever you install SnapCenter Plug-in for VMWare vSphere you will need to log out of vCenter user interface and login again so you can see plugin in vCenter GUI. This is due to VMWare limitation. You need not restart vCenter upon installing plug-in.

 

 

Re: SnapCenter 4.0 vSphere Plugin with multiple VC's

How did this go for you?  I am facing 4 vCenter 6.0 appliances, two managing vms in cDOT datacenters and two managing vms in 7-Mode datacenters.  All four are running in linked mode.

Re: SnapCenter 4.0 vSphere Plugin with multiple VC's

I have same issue SnapCenter 4.0P4 and two sites of vcenter appliance
I installed one VSC appliance to each vcenter (i couldn't work with one VSC for two VCenter)
One plugin was installed and configured on VCenter A but I can't add new plugin of VCenter B
Is it supported or need install another snapcenter that is not reasonable

 

Re: SnapCenter 4.0 vSphere Plugin with multiple VC's

Dani,

For linked mode VCSA, you need only One Snapcenter Server to manage and each VCSA need to register with seperate plugin host (1:1 mapping between Vcenter server and plugin host)

Re: SnapCenter 4.0 vSphere Plugin with multiple VC's

Yes it is supported, as above I had to do the following:

 

Removing all the plug-ins, rebooting the vCenter servers reinstalling the plug-ins again and then another reboot of each vCenter server.

 

Also make sure that you have a PTR record in DNS for the reverse lookup for the servers hosting the plug-in & the SnapCenter server, ours disappear at one point and it gave us a similar issue at a later date.