Data Backup and Recovery Discussions

Highlighted

SnapCenter 4.1 to 4.3 Upgrade - do they co-exist

Hi there

 

Planning a snapcenter 4.1 to 4.3 upgrade and want to confirm that once we deploy the data broker appliance for 4.3 and connect to vcenter that all the jobs etc will still remain active and running on the 4.1 device that is already connected the vcenter until we migrate them over via the Powershell command

 

Related to this when deploying 4.3 data broker will  we end up with two snapcenter plugins in vcenter until we decommission the 4.1 server

 

all feedback welcome 

 

thank you

3 REPLIES 3
Highlighted

Re: SnapCenter 4.1 to 4.3 Upgrade - do they co-exist

Hi ,

 

At any time Vcenter server can hold one version of snapcenter vsphere plugin only.So when you deploy 4.3 SCV(data broker) the plugin will get updated to SCV 4.3 plugin and you will see only one plugin.

After the above step you can start migration of vsphere plugin using powershell command as mentioned in the documents.

 

regards,

Ranjith

View solution in original post

Highlighted

Re: SnapCenter 4.1 to 4.3 Upgrade - do they co-exist

Hi,

No, they do not co-exist on the same vCenter but plug-in gets upgraded.
Here what I noted in my own upgrade notes when I migrated from 4.2.1 to 4.3.
"... upgrade path requires an initial setup of NDB, then migration SCV metadata to NDB, then upgrade SnapCenter Server to version 4.3.x with finaly upgrade NDB to SCV 4.3.
NetApp customers should follow the upgrade path especially if an application consistent backup for virtualized applications is desired. Please refer to NetApp documentation center for additional information."
In case you use SnapCenter VMware plug-in (SCV) only, your steps should be:

  • upgrade your Windows SnapCenter 4.1 to 4.2.1 (SCV plug-in gets upgraded to 4.1.1 on vCenter)
  • set up NDB 1.0.1D1
  • migrate SCV plug-in to NDB using PowerShell command-lets on Windows server
  • decommission Windows server
  • upgrade NDB 1.0.1D1 to SCV 4.3.x

Please be aware that migrated SCV plug-in data could become unmanageable like migrated backup policies locked for deletion. If you have any chance to start with a new SCV box, I would recommend to do.

Hope this helps. Good luck!

Regards,

Simon

Highlighted

Re: SnapCenter 4.1 to 4.3 Upgrade - do they co-exist

thank you for the quick response and clear answer

 

Check out the KB!
Knowledge Base
All Community Forums