Data Backup and Recovery Discussions

SnapCenter 4.4 vSphere Plug-in. SnapMirror update doesn't initiate when a VM wont quiesce.

davieb1969

I've upgraded a customer to SnapCenter 4.4 and now when a VM in a backup job wont quiesce it doesn't initiate a snapmirror update and the job summary doesn't show snapmirror update. If I turn off VM snapshot in the policy, the snapmirror update is initiated and snapmirror update is shown in the job summary. A bug?

1 ACCEPTED SOLUTION

Ravager

I opened a ticket on this back in november, its a confirmed bug in that version.

 

There is a new update thats in testing atm that resolves this issue so hopefully you will see it up for download in the  near future.

 

If you turn off the quiese option the snapvault/mirrors will update fine.

View solution in original post

12 REPLIES 12

davieb1969

Thanks, no sure how that's related unless you're saying move non quiescable VMs out of the datastore. Plus snapmirror was working before upgrading to 4.4

NTAp-AVS

Do you see any error messages? Could you please post them here?

Looks like this may need additional research. We recommend opening case with support to get this further analyzed

davieb1969

no messages execpt the jobs summary saying scv unable to quiesce. I've opened a call now anyway.

 

Thanks

Ravager

I opened a ticket on this back in november, its a confirmed bug in that version.

 

There is a new update thats in testing atm that resolves this issue so hopefully you will see it up for download in the  near future.

 

If you turn off the quiese option the snapvault/mirrors will update fine.

View solution in original post

davieb1969

Ah nice one. Thanks

Ravager

probibly should of been clearer.

 

Its just some bug in the sequence code, if it gets a error it skips the part that calls the update snapmirror/snapvault step.

 

And if you have a large number of windows VM's you always have a couple that fail to quiese every now and then 😞

diarmuidn

Does anyone have the Bug ID for this? Searching  the Bugs Online Dashboard has proven to be unsuccessful

dankirkwood

BURT https://mysupport.netapp.com/NOW/cgi-bin/bol?Type=Detail&Display=1363263

 

No, you can't search for it. And it's not mentioned in the readme or "known issues" for SVC 4.4.

 

Pretty awful that NetApp don't disclose the bug, haven't patched it, and leave it to unsuspecting customers to run into it and waste their time on it. We upgraded to 4.4 recently and now we have a half-working backup solution.

 

Apparently it'll be fixed in 4.5, whenever that comes out!

 

Jörg

I also wasted much time searching why replication does not work anymore. 

It is realy awfull. Now I have to disable consistency for all datastores to have a reliable backup?

 

Netapp is aware of the bug for a long time now and there is no fix. This is not what I would expect from 

enterprise level system.

OGill

This bug has been fixed by the newly released SnapCenter Plug-in for VMware vSphere 4.5 (20-Jun-2021).

Check the release notes and look for bug 1363263: https://library.netapp.com/ecm/ecm_get_file/ECMLP2877232

 

Unfortunately the bug and the kb article has not yet been updated...

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public