Data Backup and Recovery Discussions

SnapCreator 3.6 not detecting SnapDrive on the host

MMCGUIGG0408

My environment is AIX 6.1, DB2 9.7, SnapDrive for Unix 5.0P1, and SnapCreator 3.6 on FAS3240 running Ontap 8.0.2P3 - all storage is FCP luns - everything falls within the Interoperability Matrix configurations.   I can creates clones with no problem - database quiesce, snapshots, clones, unquiesce complete successfully.  However, going through the logs of the job I noticed that it does not detect SnapDrive being used on the host.  I am concerned about getting consistent snapshots of the database as they will populate all QA and Dev environments.  Any thoughts are appreciated.

1 ACCEPTED SOLUTION

MMCGUIGG0408

Resolved - snapdrived was incorrectly started in the init.rc causing it to stop.

View solution in original post

2 REPLIES 2

himanshp

Hello,

There are two ways to take snapshots in SnapCreator. Either you can use SnapCreator APIs or let SnapDrive to take the snapshot copies. SnapCreator has ability to take the consistency group snapshots too through the APIs. All you need to do is to set following variables in the configuration file.

  • NTAP_CONSISTENCY_GROUP_SNAPSHOT
  • NTAP_CONSISTENCY_GROUP_TIMEOUT

However instead of APIs if you want to let SnapDrive take the snapshots, you would require to set following variables in the configuration file.

  • SNAPDRIVE
  • SNAPDRIVE_DISCOVERY

Please see SnapCreator documentation for more details on these variables.

Hope this helps.

Thanks,

Himanshu

MMCGUIGG0408

Resolved - snapdrived was incorrectly started in the init.rc causing it to stop.

View solution in original post

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public