Data Backup and Recovery Discussions

Highlighted

SnapManager for Exchange errors

hello all,

we found in the SnapManager logs the below errors that we need to iderstand its meaning so kindly help us:

Saving dataset backup metadata...

[23:06:00.465]  SDDatasetBackupMetadataSet failed.

[23:06:00.465]  [SDAPI Error]: DFM Zapi to start iteration to list Data sets failed. Error code: 13011. Error description: HTTP POST - Timed out.

 

102

[23:06:00.465]  Unable to save dataset VSS backup metadata.

[23:06:00.465]  [SDAPI Error]: DFM Zapi to start iteration to list Data sets failed. Error code: 13011. Error description: HTTP POST - Timed out.

 

102

[23:06:00.465]  Starting dataset backup transfer now...

[23:06:00.465]  Transfering now for dataset 'SnapMgr_Exchange_EXDRUEARTOP006' with retention type 'daily'...

[23:06:01.541]  SDDatasetTransferNow failed.

[23:06:01.541]  [SDAPI Error]: DFM Zapi to start iteration to list Data sets failed. Error code: 10061. Error description: Can't connect to host (err=10061)..

 

102

[23:06:01.541]  Unable to perform dataset backup transfer now.

[23:06:01.541]  [SDAPI Error]: DFM Zapi to start iteration to list Data sets failed. Error code: 10061. Error description: Can't connect to host (err=10061)..

 

[23:06:02.602]  Backup of storage groups/databases successfully completed.

[23:06:02.602]  However, archiving the backup to secondary storage failed.

[23:06:02.618]  Unable to query autosupport settings.

[23:06:02.930]  An autosupport message is sent to the storage system of LUN [E:\DATABASES\VDRTOP012MB1\VDRTOP012MB1.DB\]

2 REPLIES 2
Highlighted

Re: SnapManager for Exchange errors

Hi,

 

There could be number of reasons for these errors, you may have to do some digging. I am just providing some pointers for you to workwith.

 

Note: If the product is under support, plz raise a ticket with NetApp and in the meantime do the basic troubleshooting and post your findings, someone will lead you further.


Atleast following components seems to be involved here:
1) DFM
2) SnapDrive/SnapManager
2a) Host Exchage VSS Framework
3) NetApp filer: Primary & vault destination

 

However, the errors posted are indicating a communication issue between DFM & SnapDrive (ZAPI back & forth).


Questions to ask yourself:
1) How busy is your DFM server ? Check if its running almost full to its capcaity:CPU/Memory ? Reboot the DFM and try again.
By default, SnapDrive will not wait longer than 60 seconds for any API calls to DFM to complete. If the DFM server is busy or under powered the SnapDrive API calls will take longer than 60 seconds leading to a timeout condition.


2) Launch SME and check the SME backup reports and go back to the date when it worked!
Q:was there any configuration changes done? SME version upgrade since last full backups ?
Q:Are you doing Exchange database verification? can you stop it and see if the backups go through ?
Q: In the SME Database Verification Settings dialog box ? Verification on destination volume?

 

3) I see VSS related erorrs.
Q:Exchanage writer host, check the application logs.

 

As this is an SME integration with DFM, following KB will give you good understanding how it works together:
https://kb.netapp.com/app/answers/answer_view/a_id/1030208

 

Thanks!

Highlighted

Re: SnapManager for Exchange errors

Hi,

 

Is the product under support ? If yes, please raise a ticket with NetApp. 

 

Looking at the errors it appears there is some kind of communication error between:
1) DFM : DFM ZAPI
2) SnapDrive Host (SDAPI)


In total, we are dealing with following components here:
1) DFM
2) SnapDrive/SnapManager for Exch Host
2a) Exchnage Host [MS VSS Framework]
3) Filer: Primary & Vault


Let's first rule out any connectivity issues between DFM & SnapDrive Host (Exchange Host):
1. If DFM is running high on resource consumption (CPU/Memory) then there is a likelihood that snapdrive API will timeout.
Try: Reboot the DFM server and Run another backup.

 

Note: Also make sure the DFM can see FILER primary & Vault and status is good.

 

2. If step 1 does not help:
Try: Launch SME console, go to backup reports and check when was the last successful backup worked ? What changes were made if any, like upgrade or whatever, check the Windows Application logs (See if there are VSS related errors). Do this : Stop/Uncheck Exchange database verification if it's selected, and run another Backup and see if it works.


I don't have SnapDrive/SME environment anymore, so can't give you exact steps.

 

Also read this doc, it has useful info on DFM and SME integartion
https://kb.netapp.com/app/answers/answer_view/a_id/1030208

 

Thanks!

Check out the KB!
NetApp Insights To Action
All Community Forums