Data Backup and Recovery Discussions

Snapcenter same installation different Installation paths

Hi All 

Can someone explain to me following behaviour:

 

Snapcenter test-environment:

Version: 4.1.0.1738

Installation path Web_App: C:\inetpub\wwwroot\SnapCenter

Repository path: C:\inetpub\wwwroot\SnapCenter\Repository

 

Snapcenter production-environment:

Version: 4.1.0.1738

Installation path Web_App: C:\Program Files\NetApp\SnapCenter WebApp

Repository path: C:\ProgramData\NetApp\SnapCenter\Package Repository

 

The Problem is that prod snapcenter search for new plug-ins in path "C:\inetpub\wwwroot\SnapCenter\Repository" and  finds nothing, because the repository is in an other path (see above):

 "Could not find a part of the path 'C:\inetpub\wwwroot\SnapCenter\Repository\cf.xml'"  in logfile "C:\Program Files\NetApp\SnapCenter WebApp\App_Data\log\SnapManagerWeb.log"

 

The effect of this is: the current plugin shows as unsupported plugin and a new one after a software update isn't recognized.

When I copy the entire contents from "C:\ProgramData\NetApp\SnapCenter\Package Repository" to "C:\inetpub\wwwroot\SnapCenter\Repository\" then all things works as expected.

 

TIA

Thomas

 
 
 
 

 

2 REPLIES 2

Re: Snapcenter same installation different Installation paths

Looks like that in the test environment you did a SnapCenter upgrade from a previous version while in the production environemt you did a fresh install. is that correct?

And  then what do you meand the SC search for new plugins in tha mentioned path?

during which operation you see that?

 

Re: Snapcenter same installation different Installation paths

Hi 

Yes this is Correct (Upgrade vs Fresh install). Thanks for your explanation.

 

regards

Thomas

 

 

Forums