Data Backup and Recovery Discussions

Highlighted

Snapcentre NFS Discovery process

Hi guys,

 

Does anyone know how snapcentre discovers which SVM to use for NFS drives? It appears to scan every SVM and look at the export policies, thing is on this environment the same subnet exists at DC1/DC2 and DC3. As such when we perform a refresh any hosts on DC2 or DC3 are automatically selected for an SVM on DC1. DOH! We see LUN's just not NFS exports, I assume this is a limitation of the NFS discovery but I'm only making assumptions by trawling through the debug logs  and drawing my own conclusions.

 

Here is what it looks like in the logs, as you can see a host in DC3 has been selected by snap centre to have its volumes in a SVM at DC1. This is a mistake of course, and I think it's due to the same subnet - if so snapcentre can't differentiate our sites and we either need to a) change the subnet b) deploy SC at each site or c) get help from NetApp to re-code so the selection process is more intelligent.

 

Here is the error:

 

NFSDIscovery.png

 

We're running Snap Centre 4.3 on 2019 server and all the hosts (there are many) are on 2019 server. As such we tried this KB for fun (thinking it may do more than it suggests) but it hasnt helped.

 

😮

13 REPLIES 13
Highlighted

Re: Snapcentre NFS Discovery process

Hi,

 

Could you share the screenshot 'storage connections list'  in your snapcenter ?

 

Thanks!

Highlighted

Re: Snapcentre NFS Discovery process

Sure, I've blanked out some of the detail to protect identity.

 

NFSDIscovery.png

Highlighted

Re: Snapcentre NFS Discovery process

Sorry for late response. Are those IP/LIF SVM management LIF or Cluster management lif?

Highlighted

Re: Snapcentre NFS Discovery process

They are SVM LIFs, the cluster LIFs are also in there on the cluster drop down. The screenshot I've posted is the SVM drop down, we're managing the SVM's independently as per this article.

Highlighted

Re: Snapcentre NFS Discovery process

Thanks for the update.

 

Just reading through the errors in screenshot you shared (SCW logs), it appers to me there is an issue in correlation of nfs export address to the actual storage system. I am not sure 100% if that's the case, but I suggest raise a tickte with NetApp right away if you haven't done it yet. In the mean time keep troubleshooting.

 

The common string in that error is giving some indications though: <BuildNfsExport-To-StoraeSystemPathsMap>

Highlighted

Re: Snapcentre NFS Discovery process

Exactly it appears it uses the export to determine the SVM. Which ain't gonna work in our environment.

 

i can log a call sure, however could you also ping a mail to a developer and ask what the actual discovery process is? 

Highlighted

Re: Snapcentre NFS Discovery process

Sorry... I am not an NetApp employee so can' get to Developer, however the right channel is to go via support ticket, and they will automatically get to the right department/people interanlly if need be.

 

There may be some developers already on this forum, so if we are lucky they might chip in, but raise a ticket.

 

In the mean time, do you mind attaching all the logs for snapcenter here to this thread,  for now - just individual job logs will do.

 

Query : Is this NFS discovery process for provisiong or cloning ?

 

How to collect SnapCenter logs:
https://kb.netapp.com/app/answers/answer_view/a_id/1030193

 

Thanks!

Highlighted

Re: Snapcentre NFS Discovery process

Anoter quick query:

 

The IPs listed in the screenshot you shared earlier, 10.x.x.111 (seen 3 times), is this unique or the smae IP but for different SVMs in different cluster ?

 

Reason I asked is : Per SnapCenter documentation it syas 'Each storage system that is supported by SnapCenter should have a unique name and a unique data LIF IP address'.

Highlighted

Re: Snapcentre NFS Discovery process

Let's wait to see if an employee responds first. The behaviour seems pretty clear, just need someone with deeper knowledge to confirm or deny. I'll log a call next week if I can't find any issues in bug tools.

Try the NEW Support Site!
NetApp Support Site
Forums