Data Backup and Recovery Discussions

Snapcreator 4.1p1 not server agent appears to start but unable connect to port 8080

Hi, I have been running SC server 4.0P1.  I upgraded it to 4.1P1 x64 and now I cannot connect on port 8080

Looking in the event log I see the following message when the SnapCreatorServerService starts.  Since it seems to be java related, I have upgrade java to the latest version - both 32 and 64 bit.  Thanks in advance for the help!  Michael.

Log Name:  Application
Source:    Application Error
Date:      4/7/2014 2:06:05 PM
Event ID:  1000

Task Category: (100)

Level:     Error
Keywords:  Classic
User:      N/A


Faulting application name: prunsrv.exe, version:, time stamp: 0x51543b9d

Faulting module name: jvm.dll, version:, time stamp: 0x52b26940

Exception code: 0xc0000005

Fault offset: 0x00000000001cd148

Faulting process id: 0xe78

Faulting application start time: 0x01cf528bc65720ad

Faulting application path: C:\Program Files\NetApp\Snap_Creator_Framework\scServer4.1P1\engine\prunsrv.exe

Faulting module path: C:\Program Files\Java\jre7\bin\server\jvm.dll

Report Id: 48bebf2b-be7f-11e3-a3a6-005056840025

Event Xml:

<Event xmlns="">


<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<TimeCreated SystemTime="2014-04-07T18:06:05.000000000Z" />
<Security />



<Data>C:\Program Files\NetApp\Snap_Creator_Framework\scServer4.1P1\engine\prunsrv.exe</Data>
<Data>C:\Program Files\Java\jre7\bin\server\jvm.dll</Data>




Re: Snapcreator 4.1p1 not server agent appears to start but unable connect to port 8080


Are you saying that this worked fine and then you upgraded to the 64-bit version?

If you open a command prompt and run:  java -version I'll guess that the reported version of Java is 32-bit. (64-bit will say 64-bit, otherwise it won't say anything).

If this is the case the issue is that the OS default version of java is 32-bit.

As such Snap Creator is not able to start the 64-bit version.

Change your OS settings so that the 64-bit version is the default version (or even uninstall the 32-bit version if that is an option).

If you want to verify that Java is the issue you can open a command prompt and change to the directory where Snap Creator is installed.

Change to the engine subdirectory and run the command:  java -jar snapcreator.jar

The error should be displayed on screen.

Please let us know if you need additional help.


Re: Snapcreator 4.1p1 not server agent appears to start but unable connect to port 8080

Hi John,

I know that I was on 4.0P1 and I ‘m pretty certain it was 64bit. I upgraded to 4.1P1 64bit. I did what you suggested and uninstalled the 32 bit version of java. No luck. I still get this error in my application event log and cannot connect to port 8080. Thanks! Here is the output from the cmd prompt when running the java –jar command:

C:\Program Files\Netapp\Snap_Creator_Framework\scServer4.1P1\engine>java -jar snapcreator.jar

Starting Derby Server

Starting Jetty Server on port: 8443

2014-04-07 16:20:12.204:INFO:oejs.Server:jetty-8.1.12.v20130726

2014-04-07 16:20:12.251:INFO:oejdp.ScanningAppProvider:Deployment monitor C:\Program Files\Netapp\Snap_Creator_Framework

\scServer4.1P1\engine\wars at interval 1

2014-04-07 16:20:12.251:INFO:oejd.DeploymentManager:Deployable added: C:\Program Files\Netapp\Snap_Creator_Framework\scS


2014-04-07 16:20:14.825:INFO:oejw.StandardDescriptorProcessor:NO JSP Support for /ui, did not find org.apache.jasper.ser


2014-04-07 16:20:14.903:INFO:oejd.DeploymentManager:Deployable added: C:\Program Files\Netapp\Snap_Creator_Framework\scS


2014-04-07 16:20:16.588:INFO:oejw.StandardDescriptorProcessor:NO JSP Support for /services, did not find org.apache.jasp


2014-04-07 16:20:16.619:INFO:services:Initializing Spring root WebApplicationContext

16:20:23,966 ERROR SchemaUpdate:235 - HHH000388: Unsuccessful: create sequence hibernate_sequence start with 1 in

crement by 1

16:20:23,966 ERROR SchemaUpdate:236 - Sequence 'HIBERNATE_SEQUENCE' already exists.

Property file changed, updating property object.

2014-04-07 16:20:35.479:INFO:oejus.SslContextFactory:Enabled Protocols of [

SSLv2Hello, SSLv3, TLSv1, TLSv1.1, TLSv1.2]

2014-04-07 16:20:35.495:INFO:oejs.AbstractConnector:Started SslSocketConnector@

Jetty Server started on port: 8443

Re: Snapcreator 4.1p1 not server agent appears to start but unable connect to port 8080


One of the big changes from Snap Creator 4.0 to Snap Creator 4.1 is that we enabled HTTPS communications for Snap Creator.

As such you have to use a HTTPS port - the default is 8443.

I do not think we can use port 8080 as it is a HTTP port.

Looking at the above output it looks like Snap Creator connected on port 8443 since 8080 was not an option.

Can you try accessing Snap Creator on 8443?

You may need to change the port where Snap Creator runs.

You can stop Snap Creator, then go to the Snap Creator installation directory and into the engine/etc subdirectory.

If you are using the defaults this would be:

C:\Program Files\NetApp\Snap_Creator_Framework\scServer4.1P1\engine\etc

edit the file

Change this line:


To reflect whatever port you want to use that is a HTTPS supported port.  The port also needs to be available for use.

Save the file and start the Snap Creator service.

Hope this helps!


View solution in original post

Re: Snapcreator 4.1p1 not server agent appears to start but unable connect to port 8080

Aw .. Ok. It looks like I’m in business. I’m used to connecting on port 8080 so kept trying that. I read the install doc, but not change notes and didn’t see anything about the change to https. I saw during the install, it was defaulting to 8443, but I thought that was what the agent used perhaps. I did try connecting on 8443 anyway, but didn’t thing to try https especially since even the documentation I saw, it talked about connecting on 8080.

In any case, I copied my config files back in and kicked off a job which just completed successfully. What a relief!

Thanks for the help.

Re: Snapcreator 4.1p1 not server agent appears to start but unable connect to port 8080

Glad to hear it is working now - Should have caught this one from the title


Re: Snapcreator 4.1p1 not server agent appears to start but unable connect to port 8080

Just glad you did and that it was an easy one. Thanks again.

Cloud Volumes ONTAP
Review Banner
All Community Forums