Data Backup and Recovery Discussions

Snapdrive report error when backup with SMO


Hi guys,


I get errors as:


--[ERROR] SMO-13032: Cannot perform operation: Backup Create. Root cause: SMO-11007: Error cloning from Snapshot copy: FLOW-11019: Failure in ExecuteConnectionSteps: SD-00027: Error connecting filesystem(s) [/opt/oracle/oradata/netorca/db] from snapshot smo_netorca01_netorca_f_h_1_ff8080814c5fa8f2014c5fa8f7f00001_0: SD-10016: Error executing snapdrive command "/usr/sbin/snapdrive snap connect -fs /opt/oracle/oradata/netorca/db /opt/NetApp/smo/mnt/-opt-oracle-oradata-netorca-db-20150328171512303_0 -snapname kat_svm:/vol/vol_netorca_db:smo_netorca01_netorca_f_h_1_ff8080814c5fa8f2014c5fa8f7f00001_0 -autorename -noreserve -prefixfv SnapManager_20150328171512324":
connecting netorcadbvg:
LUN copy lun_netorca_db_0 ... create failed
0003-358 Admin error: Failed to clone LUN lun_netorca_db_0 on storage system kat_svm : Clone operation failed to start: Requested space exceeds that reserved by the token.




The lun size is 5G with free space over 3G and the volume size is 25G with snapshot reserve 0 and I have prepared up 100 lun ID on host side:

dg: netorcadbvg dgtype lvm
hostvol: /dev/mapper/netorcadbvg-lvol state: AVAIL
fs: /dev/mapper/netorcadbvg-lvol mount point: /opt/oracle/oradata/netorca/db (persistent) fstype ext3

device filename adapter path size proto state clone lun path backing snapshot
---------------- ------- ---- ---- ----- ----- ----- -------- ----------------
/dev/mapper/3600a0980506570566a2b46715035694f - P 4.8g fcp online No kat_svm:/vol/vol_netorca_db/lun_netorca_db -



I choose to use RMAN with control file but I still get following warning and I have check with RMAN. There is not backup list in RMAN right now

--[ WARN] ORACLE-00105: Failed to uncatalog /opt/oracle/oradata/netorca/ctl/SMOBakCtl_1427536338545_1 from RMAN.  Most likely the file has already been uncatalogued manually or by another process, but it may need to be manually removed.


I have no idea how do the errors happen. Can someone give me some advices


Thanks all.


Re: Snapdrive report error when backup with SMO




Hope flexclone is licensed?



If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Snapdrive report error when backup with SMO


Yes, I can create snapshot and flex clone on the storage successfully

Re: Snapdrive report error when backup with SMO


i had the same problem after migrating from 7 Mode to 8.3. Try to change the san-clone-methode in snapdrive.conf from lunclone to unrestricted




this worked for me

View solution in original post

Re: Snapdrive report error when backup with SMO




It works! Thanks very much.

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums