Data Backup and Recovery Discussions

Snapdrive services fail to start

Exploring the Shares possibilities in OnCommand we turned off cifs on an interface in order to force shares through a specific subnet, using CLI to our netapp host: options interface.blocked.cifs (interface name)


After doing this we had problems backing up an SQL database, the server lost connection to disks and started asking for a valid certificate. Enabling the cifs interface again with options interface.blocked.cifs “” brought back the disks, but a problem still remains. The SnapDrive and SnapDrive Manager services stopped working.


How can we activate the services again so we can start backing up our SQL Databases again. We have tried the registry change for prolonging the shut down time for services to start. Still no result. We have tried rebooting. Reinstalling is not an option.


Any help in this matter is greatly appreciated.


This is our products in relation to the error.

Snapmanager for sql server

Sql version 2008 r2

Server OS 2008 r2

Snapdrive manegement version 7.0.3


Re: Snapdrive services fail to start



Could you please provide further information, for example: What is the error message you are recieving when the service fails to start? What are the snapdrive event ID's in your servers application event log?

This KB might be of interest to you:


Have you logged a support case?



If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: Snapdrive services fail to start

These are the two error messeges when trying to start SnapDrive service and the manager services service:


Windows could not start the SnapDrive service on Local Computer. Error 1067: The process terminated unexpectedly.

Windows could not start the SnapManager Service services on Local Computer. Error 1068: The dependency service or group failed to start.


Event log give me this:


Faulting application name: SWSvc.exe

.NET Runtime version 2.0.50727.5485 - Fatal Execution Engine Error (000007FEF941600A) (80131506)tion Engine Error (000007FEF941600A) (80131506)


Thank you for the link, I have tried the explorer settings with no result. I can't change the XML files, but that would be interesting to try since one of them is mentioned above. (SWSVC.exe) This might be due to insufficient admin right to change it.


I have a support case on this, awaiting answer.




Re: Snapdrive services fail to start



This might be of interest:


If that's no related to your servers configuration then see this KB:


this describes how to debug a windows service using windbg:



If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

Re: Snapdrive services fail to start

After changing the IE options, prolonging the service time before closure-registry-hack and updating the .NET framework we finally reinstalled the snapdrive and snapdrive for SQL-server manager and it worked again. If not restarting the server works, try reinstalling the application, right?


Anyway, thanks for the input. If anyone else is struggeling with the services not starting, reinstalling the application might be a last way out.



Re: Snapdrive services fail to start

Anyone know what the KBs here said? They are not available anymore. I'm having the exact same issue reinstalling SnapDrive on a new laptop.

Review Banner
All Community Forums