Data Backup and Recovery Discussions

VIBE application cleanup failure

clilescapario

Another intermittent error I'm seeing on VIBE configurations is happening during the application cleanup.

########## Application cleanup ##########
[2013-12-11 01:43:20,343] INFO: Performing cleanup on : vibe
[2013-12-11 01:43:24,456] ERROR: SCF-00074: Cleanup for plug-in [vibe] failed with error [org.codehaus.jackson.map.exc.UnrecognizedPropertyException: Unrecognized field "discoveredGroups" (Class com.netapp.snapcreator.agent.nextgen.common.result.Result), not marked as ignorable at [Source: sun.net.www.protocol.http.HttpURLConnection$HttpInputStream@27e45c6d; line: 1, column: 343] (through reference chain: com.netapp.snapcreator.agent.nextgen.common.result.Result["discoveredGroups"])] and exit code [-1], Exiting!

Thanks,

Chris

7 REPLIES 7

Clemens_Siebler

Hi Chris,

unfortunatly, this is a bug in 4.1c. This will be working in the 4.1 GA release.

Thanks,

Clemens

I have the same problem with cleanup not being done. Do you have an ETA for GA release?

spinks

Hi -

Snap Creator 4.1 is expected to be released approximately January 9th.

Expect an announcement here on the Snap Creator Communities page once Snap Creator 4.1 is released.

Thanks!

John

clilescapario

I'm seeing a similar intermittent error with a smsql config on 4.1 GA.

[2014-02-13 00:18:01,798] ERROR: SCF-00002: Backup handling of plug-in [smsql] failed with error [org.codehaus.jackson.map.exc.UnrecognizedPropertyException: Unrecognized field "discoveredGroups" (Class com.netapp.snapcreator.agent.nextgen.common.result.Result), not marked as ignorable at [Source: sun.net.www.protocol.http.HttpURLConnection$HttpInputStream@3baaca14; line: 1, column: 290] (through reference chain: com.netapp.snapcreator.agent.nextgen.common.result.Result["discoveredGroups"])] and exit code [-1], Exiting!
[2014-02-13 00:18:17,119] DEBUG: Application specific backup_cleanup operations are not yet implemented for plugin smsql

Thanks,

Chris

Any ideas on this still being a problem in 4.1? I've opened a case but I seem to be having my usual luck (ie - no resolution, ever).

Thanks

--

Chris

spinks

Chris,

I'm afraid I don't have an answer off the top of my head.

What version are you running now?  4.1?

It looks like you are now getting this error with the smsql plugin?

Are you still getting it with the VIBE plugin as well?

Can you share the case# with me? 

You can email me at spinks at netapp d0t com

I'll see if there is a defect of RFE planned for this.

If not maybe we can get it listed in the next patch.

Thanks,

John

clilescapario

The issue was resolved for VIBE with upgrade to 4.1, but then became present with SMSQL configs.

Thanks,

--

Chris

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public