Data Backup and Recovery Discussions

Windows Server 2008 R2 sees lun twice... Host utils are installed!

oweinmann

Hi,

We have a very strange problem here.

Server 2008 R2 1 Qlogic HBA FC hostutils 5.3 installed. Connected luns are shown twice. I remeber that this was a problem if hostutils are not installed. But even with hostutils installed the luns are shown twice. This server only has one connection to the fc fabric.

Any suggestions?

Regards,

Oliver

4 REPLIES 4

ken_foster

you are having a multipathing issue.  you probably have an  HA pair, running in single image.  without MPIO configured you will always see multiple copies of your LUNs.

oweinmann

This is the only server in our environment where we have this issue. I remember we had this once on a windows 2003 machine where snap drive wasn't installed. The installation of snap drive solved this issue. I have a virtual 2008 server FC Host utils installed snap drive installed I see the lun only once. The same setup on the physical machine shows the lun twice.

oweinmann

Problem Solved.

I installed the Windows MPIO Feature, restarted the machine and reconnected the lun.

I don't know why this worked. On the VM there is no Microsoft MPIO feature installed and it works out of the box.

Cheers,

Oliver

ken_foster

i think i have an idea why the VM didn't have a problem.

The VM is probably accessing VIA iSCSI.  the other machine is probably accessing VIA FCP.  with FCP the VTIC is a valid path  with iSCSI it isn't.  Again, this is all supposition since i don't have a diagram but thats how it played out in my head.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public