Data Backup and Recovery Discussions

[gui-00025] Invalid vCloud Credentials!

Running SnapCreator_Framework_3.6.0-Win64 on Windows Server 2008 Standard, we are unable to successfully connect to vCloud Director 1.5 when creating a backup profile.

Within the SnapCreator GUI, we supply the vCD URL (assume https://10.10.10.10/cloud for this example) and a local system administrator name defined within vCD (assume a system administrator user in vCD called sc_backup) as sc_backup@system and its associated password. However, when we try to connect to vCD, we always receive error "[gui-00025] Invalid vCloud Credentials!". If we follow that same URL outside of the SnapCreator GUI and use account sc_backup with its password, login is successful.

From within the SnapCreator GUI, we have double (and triple checked) that we are entering the correct password for sc_backup. We have tried entering the username as sc_backup and sc_backup@system. Same result always - [gui-00025] Invalid vCloud Credentials!. What are we missing?

15 REPLIES 15

Re: [gui-00025] Invalid vCloud Credentials!

I am having the same issue, did you manage to find a resolution to this issue?

Re: [gui-00025] Invalid vCloud Credentials!

It is a permissions issue of some kind, hard to tell based on info and I really dont have that much experience with vcloud. I do know we need @system user and it needs to be an admin but I think the @system user is an admin.

The other thing it could be is firewall, maybe SC server is being blocked to vcloud director. Are they on same subnet? If not I would check this

I would open a support case or maybe someone else will chime in with some ideas

Regards,

Keith

Re: [gui-00025] Invalid vCloud Credentials!

Hi Keith - I'm having this same issue with snapcreator framework 3.6, trying to create a configuration using the vCD plug-in to connect to a vCloud Director 5.1.1 cell.  As in the initial post, i've tried passing the credentials muliple ways to no avail;  i've tried local system administrator account established in vCD (Administrator@system), i've tried going directly to a specific organization using the local org administrator account, etc.  It always results in [gui-000025] Invalid vCloud Credentials.  Logging in with these credentials directly through the vCD UI works correctly.  Also, i tried using the vSphere plug-in just to confirm functionality, and I can sucessfully create a configuration using the vSphere plug-in going direct to the vCenter Server that supports vCD.  I've opened a case with NetApp support, but they have no information on this issue.  Have you heard anything more about this in the months following your response?

Re: [gui-00025] Invalid vCloud Credentials!

Hello Don,

Could you please try this and let me know the result?

Example, if on a windows system where snapcreator server is installed.

C:\Program Files\NetApp\Snap_Creator_Framework\scServer4.0.0c>snapcreator.exe --pwdCrypt

Please Enter Password:

Your encrypted password is: 365a4f6c6f7157525331492d0a

Supply your vCD password in the above example, and obtain a Crypted password.

Then supply that password when try to connect to the vCD via snapcreator.

I don't have a lab gear with vCD install.

If you could test this and reply it is useful.

I will also cascade this information to the snapcreator developers.

Thanks,

Siva Ramanathan

Snapcreator Community Moderator

Re: [gui-00025] Invalid vCloud Credentials!

Hi Siva;

thanks for the reply!  The --pwdCrypt option doesn't appear to be valid with SnapCreator 3.6.

Don

Re: [gui-00025] Invalid vCloud Credentials!

Thanks Don.

Sorry about that. I missed to see that.

I will this in the lab and will let you know asap.

Thanks,
Siva Ramanathan

Re: [gui-00025] Invalid vCloud Credentials!

Is 4.0 available?  I'd be willing to upgrade if so, but I don't see it on the Downloads page.

Re: [gui-00025] Invalid vCloud Credentials!

4.0 community edition is expected to be released in 2 weeks.

https://snapcreator.netapp.com/download


Also has a version of 4.0.0c

I am reaching out to my peers to test the login issue meanwhile.

Re: [gui-00025] Invalid vCloud Credentials!

Don,

I believe that the 3.6 option is --cryptpasswd

You can run the snapcreator command by itself and it should list all of the options.

This should be one of the last ones listed.

Hope this helps.

John

Re: [gui-00025] Invalid vCloud Credentials!

Have you tried running this from the command line to see if you experience the same behavior?

Re: [gui-00025] Invalid vCloud Credentials!

ah, right you are John...i blew right past it.  I'll give it a shot.

Re: [gui-00025] Invalid vCloud Credentials!

Hi Siva; 

John Spinks pointed me toward the --cryptpasswd option and i tried to authenticate as administrator@system with the encrypted password and got the same result.  One thing i'm curious about though is in this context, should i check or uncheck the password encryption check box in the configuration...i've tried both ways, same result, but i'm curious now what it is exactly that i'm testing here.

Thanks!

Don

Re: [gui-00025] Invalid vCloud Credentials!

Hi Siva;

how'd things to in the lab...were you able to reproduce this issue?

Don

Re: [gui-00025] Invalid vCloud Credentials!

Don -

I think Siva is traveling at the moment.

Generally speaking, With the password encryption box unchecked you should be able to use plain text passwords.

With the box checked you can use encrypted passwords that are either encrypted automatically through the GUI or through the --cryptpwd option in the CLI.

I do not have a vCloud environment, so I cannot test.

Hopefully Siva can get back to you soon.

Matt asked below if you were able to test this via the Snap Creator command line.

We are just wondering if the behavior is the same on the CLI as it is on the GUI.

Thanks!

John

Re: [gui-00025] Invalid vCloud Credentials!

very good - thanks John!

Cloud Volumes ONTAP
Review Banner
All Community Forums
Public