Data Backup and Recovery Discussions

run POST_CLONE_CREATE on SC_CLONE_TARGET

mauro

I have Snapcreator 4.0p1 server on windows and snapcreator 4.0p1 agent on Linux with Oracle.

I would like to use "clone vol" action , map luns on a third linux machine (test machine), then run a script on the test machine for  import vx dg and mount filesystem.

Here the main variables used in config file:

SC_AGENT=oraprod6N:9090  (the PROD oracle machine)

NTAP_CLONE_IGROUP_MAP=fas6280a:as_lnx180_as_lnx181_oraprod6_dg_bin/ig_as_lnx150_as_lnx151;fas6280a:as_lnx180_as_lnx181_oraprod6_dg_ctl/ig_as_lnx150_as_lnx151;fas6280a:as_lnx180_as_lnx181_oraprod6_dg_data1/ig_as_lnx150_as_lnx151;fas6280a:as_lnx180_as_lnx181_oraprod6_dg_data2/ig_as_lnx150_as_lnx151;fas6280a:as_lnx180_as_lnx181_oraprod6_dg_temp/ig_as_lnx150_as_lnx151;fas6280a:as_lnx180_as_lnx181_oraprod6_dg_redo/ig_as_lnx150_as_lnx151;fas6280a:as_lnx180_as_lnx181_oraprod6_dg_sibapp/ig_as_lnx150_as_lnx151

(lun mapped on the TEST machine)

SC_CLONE_TARGET=10.47.77.110:9090 (the TEST machine)

POST_CLONE_CREATE_CMD01=/opt/netapp/script_sc/post_mount_test.sh  (script for mount fs from cloned luns on the TEST machine)

I expect that the script will run on the test machine, but it seems executed on the agent oraprod6N (PROD machine)

[2013-10-08 16:01:11,400] INFO: [oraprod6N:9090 (4.0.0.1)] Executing Post clone create command [/opt/netapp/script_sc/post_mount_test.sh] on oraprod6N

[2013-10-08 16:01:11,400] DEBUG: [oraprod6N:9090 (4.0.0.1)] Executing command [/opt/netapp/script_sc/post_mount_test.sh]

[2013-10-08 16:01:11,400] TRACE: Command [/opt/netapp/script_sc/post_mount_test.sh] finished with

exit code: [-1]

Why?

From installation guide

SC_CLONE_ TARGET:

Snap Creator has the capability to perform clone operations.

Using the action cloneVol in combination with {PRE|POST}_CLONE_CREATE_CMDxx, you can handle the storage objects on the remote side. For example, mounting/

unmounting file systems. To specify a clone target, enter its name or IP address followed by a colon and the port the Snap Creator Agent is listening on.

many thanks,

Mauro.

1 ACCEPTED SOLUTION

ktenzer

Try this to specify the clone target

POST_CLONE_CREATE_CMD01=CLONETARGET: /opt/netapp/script_sc/post_mount_test.sh

You can user SERVER:, AGENT:, or CLONETARGET: with all commands

Regards,

Keith

View solution in original post

2 REPLIES 2

ktenzer

Try this to specify the clone target

POST_CLONE_CREATE_CMD01=CLONETARGET: /opt/netapp/script_sc/post_mount_test.sh

You can user SERVER:, AGENT:, or CLONETARGET: with all commands

Regards,

Keith

View solution in original post

mauro

it works!!

many thanks.

ciao.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public