Data Backup and Recovery Discussions

snap manager for oracle, restore job fails

1. database is shutdown by smo during the backup. manually shutdown prior to the restore.

version oracle os solaris 10

SMO version 3.3

cold backup taken with SMO

complete restore with no recovery, override chosen for fast restore.

restore preview shows all mounts capable of fast restore.

Fuser -cu shows no activity on the mount that causes the failure. there are 6 mounts for this database, each time I run the recovery a different one causes the problem. here is the error message...

snapdrive log shows this error

11:39:55 10/28/10 [397]e,2,10,FileSystem::deactivate: /dwuat_data4 unmount failed 12: UX:vxfs umount: ERROR: V-3-21705: /dwuat_data4 cannot unmount : Device busy

however, nothing on this host is in this mount. any ideas?


Re: snap manager for oracle, restore job fails


you tried unmounting that mount manualy using snapdrive? does it throw the same error?



Re: snap manager for oracle, restore job fails

i can successfully perform the snap restore in about 5 minutes using snapdrive commands. the problem is something in the SMO process.

Review Banner
All Community Forums