Data Backup and Recovery Discussions

snapvault - protection manager



I figured out how to setup the SMSQL5.0 snapvault integration with Protection Manager (4.0).  I used a combination of the TR-3768 and the SMSQL 5.0 Installation and configuration Guide. In the TR there was stated to select the protection policy "Remote Backups Only". Strange enough this policy has by default a throthle "Nightly Transfer Window", that prevents transfer during office hours and therebye the conformance failed. This was solved through changing the throthle to None.

My question: Is the snapvault transfer initiated by the snapmanager or by the protection manager ? If it is the first, what does the schedule from the PM do then ? If it is the last, doesn't this result in inconsistent snapshots ?





SMSQL quieces the database(s) then takes a snapshot on the primary using Snapdrive. It then uses Snapdrive to communicate with Protection Manager which then starts the snapvault transfer using the snapshot on the primary just taken.

You can define your own protection policy that doesn't have a throttle set. It just has to be a policy that does the equivalent of "remote backup only".



That's stange then, because I follewed the guidelines but my relation doesn't update automatically.


Check your SMSQL logs for the most recent backup. Those should indicate what the failures were. I'm assuming the databases are correctly configured for an archive backup?

If you are using Netapp Management Console you should also be able to check on the last job that ran under that protection policy, if it got that far.



I was just thinking the same and finished checking the last full backup logfile. Backup/Verify succeeded:

[00:22:30.621]  *** SNAPMANAGER BACKUP JOB ENDED AT: [07-27-2010 00.22.30]
[00:22:30.621]  Full database backup with verification completed successfully.

But there is nowhere in de logfile any link to the snapvault update, protection manager policy, snapdrive, ...

I was expecting to find SnapMgr_SQLServer_RMGINFRA01, which is the data set name created during configuration ?

Configuration was completed without any problem: data set created and thereafter destination assigned through provisioning (volume/qtree's created).

Full backup runs once a day and at the moment I've lag that equals with the last manual "protect now" for the data set.


Maybe I've found the problem.

I KB58272 they say that the user that connects the OM should have GlobalFullControl. I gave the user the role GlobalDataProtection. This was enough to let the user create the data set and I thought it would be enough to get the protection rolling (role details: manage backups and datasets). Probably this is not enough, so I will change the role to GlobalFullControl.

I find this really drastic (why did they implemented the rbac then in the first place) and this isn't (good) documented in the install/administration guide or best practices !

Anyway, hopefully it will solve my issue...


Yesterday I was hoping the issue would be solved by adding the extra roles, but it didn't.

My data set updated, but not at the time of the snapmanager taking a full backup, but at the time the schedule was set in the protection manager (1PM).

If I compare the default protection policy with the one I created, I see the following differences:

Remote backups only  (default)

1. Primary data : Local Backup Schedule : none

2. The Primary data to Backup schedule is "First Sunday at 8:00PM plus weekly and daily"

3. Throttle : Nightly transfer window

3. Backup retention duration: Hourly 0 hours, Daily 2 weeks, Weekly 8 weeks, monthly 14 weeks

SQL Server Remote backups (custom one created)

1. Primary data : Local Backup Schedule : none

2. The Primary data to Backup schedule is "Daily @1PM"

3. Throttle : None

3. Backup retention duration: Hourly 1 weeks, Daily 1 weeks, Weekly 2 weeks, monthly 8 weeks

The backup retention change is for trial, because at this time I only have my snapvault comming over to the second tier, but no retention at all. I set no throttle (not needed) and had set a daily schedule at 1PM. This is actually the time the snapvault is triggered at this moment. Since we want the snapmanager to trigger it, I changed it to a new one "Monthly - No schedule" !

If I look at the job overview in PM I see this for the data set: Could not find any backups to transfer on Primary data node of application dataset SnapMgr_SQLServer_RMGINFRA01(20434).

If I check it on the dfm server:

C:\>dfpm backup list SnapMgr_SQLServer_RMGINFRA01
There are no backups.

From what I read in the doc kb58938, I should see at least one or more entries like these here (even if the snapvault transfer doesn't work):

10121   02 Jun 2010 01:15:20  unlimited    Primary data   06-02-2010_01.14.49

If I snap list one of the volumes on the primary that are part of the data set, I see the following snapshots:

roesnap1> snap list rmginfra01data
Volume rmginfra01data

  %/used       %/total  date          name
----------  ----------  ------------  --------
21% (21%)    2% ( 2%)  Jul 28 00:16  sqlsnap__rmginfra01__recent
41% (31%)    5% ( 3%)  Jul 27 00:16  sqlsnap__rmginfra01_07-27-2010_00.15.37__daily
48% (17%)    6% ( 1%)  Jul 26 00:16  sqlsnap__rmginfra01_07-26-2010_00.15.47__daily
52% (15%)    8% ( 1%)  Jul 25 00:16  sqlsnap__rmginfra01_07-25-2010_00.15.30__daily
58% (22%)    9% ( 2%)  Jul 24 00:17  sqlsnap__rmginfra01_07-24-2010_00.15.34__daily
59% ( 5%)   10% ( 0%)  Jul 23 14:08  roesnab1(0118052941)_rmginfra01data_sv_rmginfra01data-src.3 (snapvault)
59% ( 2%)   10% ( 0%)  Jul 23 13:40  roesnab1(0118052941)_SnapMgr_SQLServer_RMGINFRA01_backup_1_RmgInfra01SqlData-src.0 (snapvault)
62% (19%)   12% ( 2%)  Jul 23 00:16  sqlsnap__rmginfra01_07-23-2010_00.15.41__daily
67% (25%)   14% ( 2%)  Jul 22 00:16  sqlsnap__rmginfra01_07-22-2010_00.15.26__daily

Like you see above, there is also another snapvault relation from the previous setup with script (before integration with PM) which I don't want to delete at this time !

Another strange thing I see is the not match between source (Jul 23 13:40) and destination (Jul 28 01:00) snapshot in the snapvault relation.

roesnab1> snap list  SnapMgr_SQLServer_RMGINFRA01_backup_1
Volume SnapMgr_SQLServer_RMGINFRA01_backup_1

  %/used       %/total  date          name
----------  ----------  ------------  --------
  5% ( 5%)    0% ( 0%)  Jul 28 01:00  roesnab1(0118052941)_SnapMgr_SQLServer_RMGINFRA01_backup_1-base.6 (busy,snapvault)

Feedback is more than welcome at this time !!




Now I really found the cause !

We had our backup jobs already running (created before integration with PM took place). It wasn't described in the Best Practices either, but you have to change the backup job to. It doesn't ends after integration is finished !

If you create a new job with Backup Wizard, at Verification Settings tab there is a section Backup Archiving Options, where you must select "Archive Backup to Secondary Storage" (see picture attached). It's that simple !

Hopefully this will help ohter people that want to integrate snapmanager - snapdrive with Protection Manager.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner