Data Backup and Recovery Discussions


vSphere client plugin cannot reach SnapCenter server after IP change

Hello all.


We had to change the SnapCenter server's IP address, and now the vSphere web client SnapCenter plug-in fails to reach it.

All spinners keep running for a few seconds, then a box pops up with the following message :

Failed to load dashboard content.
Could not fetch dashboard data. Verify that SnapCenter Plugin for VMware vSphere service is running. If the service is down, start the service and try again.


I tried to update the vCenter and SnapCenter details with the arrow button on the hosts page in SnapCenter, to no avail.

Also tried to register the plugin again (https://<snapcenter_ip>:8144/register.html), same.


tcpdump on the vCenter show me that it's trying to reach the old address (ARP requests), but I have no idea where it gets it from.


Any clue on how to fix this ?


Re: vSphere client plugin cannot reach SnapCenter server after IP change

Got it.


The old IP address can be viewed in the vCenter's Managed Object Browser (https://<vcenter>/mob/?moid=ExtensionManager&doPath=extensionList%5b%22com%2enetapp%2eaegis%22%5d%2eclient).

It actually show up in both com.netapp.aegis and com.netapp.scvm.webclient extensions, and in both the client and server URL string.

Couldn't find a simple way to update those URLs, so I just unregistered the plugins, and registered them again from https://<snapcenter_ip>:8144/register.html.


Problem fixed !

View solution in original post

Check out the KB!
Knowledge Base
All Community Forums