Data Backup and Recovery

Backing up a vApp with SC3.6

yweisser
3,294 Views

Hi all,

I m trying to configure SC3.6 to backup vApps, but there are some issues/questions...

- does the Agent require an access to the storage?

- is VSC required?

- do all bricks need to have the same timestamp?

When I create my configuration (around VCD plug-in) & that I run a job, I get an error saying that the plug in does not support the action "snap"...

=> which actions are supported with VCD ?

thanks for your help

8 REPLIES 8

ktenzer
3,295 Views

- does the Agent require an access to the storage? No

- is VSC required? No

- do all bricks need to have the same timestamp? The snapshots takes is based on the configuration file and all vApps part of configuration will have same timestamp.

When I create my configuration (around VCD plug-in) & that I run a job, I get an error saying that the plug in does not support the action "snap"...

=> which actions are supported with VCD ? No idea what this error means can you send a log file?

Keith

yweisser
3,296 Views

Hi Keith,

  • We managed to install the server & the agent of SnapCreator
  • Creating a configuration looks pretty straight forward, & I m sure we did enter the right information
  • Creating a schedule is also easy, but when running it, it does not perform the snap job we want

     (by the way, we are using SC 3.6)

I attached the debug_log file so that you see everything.

In the discovery part of the process, here is the error:

[Wed Nov  7 11:55:04 2012] [172.16.0.164:9090(3.6.0.1)] INFO: IP address (v4-primary-address) 10.10.10.58 found.

[Wed Nov  7 11:55:04 2012] [172.16.0.164:9090(3.6.0.1)] DEBUG: Adding IP address 10.10.10.58 for storage controller/vserver 10.170.232.58 ...

[Wed Nov  7 11:55:04 2012] [172.16.0.164:9090(3.6.0.1)] DEBUG: Storage controller/vserver login successful.

[Wed Nov  7 11:55:04 2012] [172.16.0.164:9090(3.6.0.1)] DEBUG: Collecting vSphere and storage configuration data ...

[Wed Nov  7 11:55:04 2012] [172.16.0.164:9090(3.6.0.1)] DEBUG: Checking to ensure our list of storage controllers/vservers is correct for all Datastores ...

[Wed Nov  7 11:55:04 2012] [172.16.0.164:9090(3.6.0.1)] ERROR: [vmw-00150] VOLUMES is empty -- not updating (please check NTAP_USERS and VIBE configuration values!)

[Wed Nov  7 11:55:26 2012] [172.16.0.164:9090(3.6.0.1)] ERROR: [scf-00049] Auto Discovery for plugin vibe failed with exit code 1, Exiting!

We have only one storage system (FAS3140) & are logged with root…

VIBE parameters look ok as well, as we can discover all the apps…

Maybe we missed something, but what… hard to debug …

Thanks for your help!

ktenzer
3,296 Views

Set VOLUMES=auto:detect in config file and save and rerun

Somehow VOLUMES is blank or null just set to auto:detect and VIBE will add whatever volumes it discovers overwriting it

Keith

yweisser
3,296 Views

I will check that

but from what I remember it was set to auto_detect in the global config

i ll get back to you

thanks!

ktenzer
3,296 Views

Yeah VIBE is trying to update the actual config file not the global but still if it is in global it should work as VOLUMES=auto:detect would be picked up

Try adding to actual config then I bet it works

Keith

yweisser
3,296 Views

Hi Keith,

unfortunately, the test did not succeed with the idea I provided

I attached the conf file & the debug one to see if you spot another problem

thanks!

ktenzer
3,296 Views

Config looks good, if you are using global config try without otherwise only thing I can think of trying is disable agent. SC server can talk directly to vCenter so you dont need agent. If you comment out SC_AGENT then SC server will go directly to vCenter.

Hope this helps

Keitb

rmatt
3,296 Views

Keith, did we get to the bottom of this one?  Is this something to address for 4.0?  Thanks!

--Matt

Public