Data Backup and Recovery

Problem with MySQL plugin deployment for SnapCenter

tkpf
11,166 Views

Hi,

I want to backup MySQL database with SnapCenter 2.0. I know it's not supported by NetApp Support but only NetApp Community.

Then, I downloaded the plugin "MySQL v1.0" from the NetApp Community and want to deploy the plugin to my MySQL Server.

 

The deployment failed with the following error :

"Java (JRE) 1.7 or higher needs to be installed on the host "b2wdbtest02". Check the Installer log "\\xxxxxxxxxxxxx\C$\Windows\SnapCenter plugin\Install_7989\SnapCenter_Windows_Host_Plug-in_Install_7989.log" for more information"

 

In detail on the log file :

"6-12-2017[02:52:44]: Engine: property 'IS_JAVA_FOUND' value now 'False'
6-12-2017[02:52:44]: (CLR Action): SWInstallerHelper GetJavaVersion: Begin Getting Java Version.
6-12-2017[02:52:44]: (CLR Action): SWInstallerHelper GetJavaVersion: FeatureInstall : SCC
6-12-2017[02:52:44]: (CLR Action): SWInstallerHelper GetJavaVersion: After OpenSubKey
6-12-2017[02:52:44]: Engine: property 'JavaVersion' value now '1.7'
6-12-2017[02:52:44]: (CLR Action): SWInstallerHelper GetJavaVersion: ERROR: Exception in GetJavaVersion: Input string was not in a correct format.
6-12-2017[02:52:44]: (CLR Action): SWInstallerHelper GetJavaVersion: Error: Java(JRE) 1.7 or higher needs to be installed on this machine.
6-12-2017[02:52:44]: Engine: property 'IS_JAVA_FOUND' value now 'False'
6-12-2017[02:52:44]: Action 'CA_GetJavaVersion' returned status 0x00000000"

 

Java JRE 1.7 is installed ont he computer.

 

I saw on registry :

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\Current Version > REG_SZ  >  1.7

 

Could you please help me. I found any solution or post about this issue.

Thanks in advance for your feedback.

19 REPLIES 19

spinks
11,107 Views

In general with Java I have seen that the Java installer defaults to a 32-bit version of Java, but SnapCenter needs a 64-bit version of Java.

 

Open a command prompt and type: java -version

If the output does not mention it is a 64-bit version, then it is a 32-bit version.

 

You should install a 64-bit version of Java.

It has been requested to add a test to this to SnapCenter and provide a clear error message in the future.

 

Hope this helps,

John

tkpf
11,057 Views

Hi,

 

Thanks for your feedback. I cheched the Java version :

 

C:\Users\xxxxxxxx>java -version
java version "1.7.0_60"
Java(TM) SE Runtime Environment (build 1.7.0_60-b19)
Java HotSpot(TM) 64-Bit Server VM (build 24.60-b09, mixed mode)

 

It seems to be already in 64bits.

I really don't understand what is wrong.

amarnatr
11,040 Views

Hi,

 

Can you add java to the PATH variable and also update JAVA_HOME in the windows host environment variables.

 

 

Thanks,

Amar

tkpf
10,990 Views

Hi,

 

I added  :

- PATH C:\Progra~1\Java\jre7\bin

 

I created :

- JAVA_HOME "C:\Progra~1\Java\jre7"

- JAVA_JRE "C:\Progra~1\Java\jre7"

 

I have the same error. (

nishant10
10,915 Views

The registry entry we are looking for is: HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.8

 

Screen Shot 2017-06-16 at 2.43.04 PM.png

 

 

 

Please share your OS version.

 

 

 

Nishant

tkpf
10,854 Views

Hi,

 

The server I want to deploy the MySQL plugin is "Windows Server 2012 R2 x64".

The requested Java version is 1.7 or later ("SWInstallerHelper GetJavaVersion: Error: Java(JRE) 1.7 or higher needs to be installed on this machine.")

See below the registry of the destination server :

 

java.png

 

I alson tried with the last version of JRE8.

 

java1.8.png

 

The error is the the same, but with JRE 1.8.

 

6-19-2017[09:08:17]: (CLR Action): Enumerating available runtimes...
6-19-2017[09:08:17]: (CLR Action): Highest available runtime: v4.0.30319 <<<<<<<<<<<< I don't know what it is ????
6-19-2017[09:08:17]: (CLR Action): Trying to use highest runtime...
6-19-2017[09:08:17]: (CLR Action): Using highest version runtime...
6-19-2017[09:08:17]: Engine: property 'IS_JAVA_FOUND' value now 'False'
6-19-2017[09:08:17]: (CLR Action): SWInstallerHelper GetJavaVersion: Begin Getting Java Version.
6-19-2017[09:08:17]: (CLR Action): SWInstallerHelper GetJavaVersion: FeatureInstall : SCC
6-19-2017[09:08:17]: (CLR Action): SWInstallerHelper GetJavaVersion: After OpenSubKey
6-19-2017[09:08:17]: Engine: property 'JavaVersion' value now '1.8'
6-19-2017[09:08:17]: (CLR Action): SWInstallerHelper GetJavaVersion: ERROR: Exception in GetJavaVersion: Input string was not in a correct format.
6-19-2017[09:08:17]: (CLR Action): SWInstallerHelper GetJavaVersion: Error: Java(JRE) 1.7 or higher needs to be installed on this machine.
6-19-2017[09:08:17]: Engine: property 'IS_JAVA_FOUND' value now 'False'

 

Thanks in advance for your feedback.

nishant10
10,825 Views

We debugged and looks like the issue is an error happening while parsing the java version("1.8").

 

One possible reason for that can be that decimal separator on your machine can be other then a dot (.), so can you verify the decimal seprator in your system and let us know what it is. Here are the steps to find it out. 

- Open "start menu" and start typing regional.

- Select Change date, time or number formats.

- Go to additional settings.

- Under the numbers tab.

- The decimal separator value.

 

If in case the decimal separator is not dot (.), can you change it to dot(.) and try out the installation again.

 

 

Screen Shot 2017-06-20 at 5.49.43 PM.png

tkpf
10,755 Views

Hi,

 

I checked the parameters, indeed "," was defined. I changed to "."

Nothing changed, I have the same error.

 

I also tried with English language instead of French, same issue.

 

 

nishant10
10,757 Views

Can we have a webex call?

 

Let me know the suitable time for you.

 

Also, give me your email id and I will send the webex link.

matte
10,375 Views

What do you mean with " i changed the system language"?

 

are you talking about the Format language or the locale settings?

 

please confirm that you have English as locale..

 

Capture.JPG

tkpf
10,346 Views

Hi,

 

As you asked, I also changed "System locale language", I didn't changed last time ;(

I changed from "French (France)" to "English (Unites States)".

 

The problem is still the same, I rebooted the server too.

 

shivakumar
10,337 Views

Could you please post the latest logs here and also let me know the time that works for you for webx

tkpf
10,292 Views

Hi,

 

I tested on 2 differents server :

 

2008 Server, PlugIns failed.

See in attachement the log

 

 

 

 

 

amarnatr
7,138 Views

Hi,

 

On your windows 2008 machine, the previous error is no more coming up.

 

On the windows host, Windows Managment Framework 4.0 is required. You can install it from the following locaiton and then proceed with the installation.

https://www.microsoft.com/en-in/download/details.aspx?id=40855

 

Thanks,

Amar

tkpf
10,287 Views

Hi again 😉

 

And the second server, a Windows 2012 server with failed plugins installation.

See in attachment :

 

 

shivakumar
7,098 Views

Hi

 

On windows 2012 setup could you please try by checking the option "Skip Pre install checks"

 

Thanks

Shiva

tkpf
7,054 Views

Hi,

 

I don't have this choice :

 

skip.png

 

I have SnapCenter Server 2.0, Build 2.0.0.29.53

shivakumar
7,029 Views

Hi,

 

OK. Yes its not in SC 2.0 release  and its in SC3.0. To check further on this we need webx and do let us know time that works for you

 

Thanks

Shiva

matte
10,271 Views

Hi

 

for the first one seems the error is different

 


6-28-2017[03:06:51 PM]: (ISP Action): SILENT INSTALL : ERROR : The following items are required to continue with this setup:
6-28-2017[03:06:51 PM]: (ISP Action): SILENT INSTALL : ERROR : Microsoft Windows Management Framework v4.0
6-28-2017[03:06:51 PM]: (ISP Action): SILENT INSTALL : ERROR : Aborting the setup.

 

 

Public