Data Backup and Recovery

SnapCenter issues and questions




I tried using SnapCenter 1.0.1 with the SQL plugin and VSC connection.

I added both primary and secondary SVMs.


It would be nice to have a built in uninstall option for the existing SnapDrive. Anyway the installation was very easy, also adding a SQL server.


It listed all the instances, DBs etc. So far so good.

However no iSCSI connections nor disks got displayed; when trying to create a new backup policy it could not find the seconday SVM used with SnapVault.

Altough I was able to choose a Logfolder from the iSCSI drives of the SQL Server.

Peering and SnapVault have already been configured and used by SnapManager for SQL so far.


As I could not find a good reason why it doesn't recognize the SnapVault destination SVM I gave up and reverted to SnapManager again.


Then I setup the VSC-SnapCenter connection, but I could not find any difference.

I was hoping to see the existing backup jobs from VSC in SnapCenter but nothing. 

The only thing I can see is the green icon for my vCenter host.

I can't figure out the benefit.


How are your experiences with SnapCenter?






My experiences with SnapCenter have not been great version 1.01 it seems to have a lot of issues and upgrading to 1.1 while addressing some issues caused more.


Unfortunately I don't think this product is currently production ready and have now dropped it from my new environment in favour of SnapManager for SQL.


It's a shame because SnapManager for SQL is not great when you have over 30 SQL servers to manage while SnapCenter (once Netapp have addressed all of the bugs) will be a far superior product, being able to manage all of your backup jobs though one pane of glass.





I would like to tell you try Snap Center 1.1 and hope all you questions are answered. 




I would agree with the prior poster, 1.0.1 is not production ready for SQL backups I spent a lot of time implementing it and messing around with various undocumented errors for the same reason of a lot of SQL servers to manage and then gave up in favour of latest SMSQL/SD also. It's too new of a product to use in a production environment yet and support is hard to get. We are keeping it in place though for VSC policy integration and using the Netapp snapshot labelling function of these policies to then apply CDOT protection policies to specify retention of labelled snapshots, so it has come in handy there.. if the backups fail though for VSC now I am finding it hard to troubleshoot as its the SnapCenter server reporting the errors not the VSC server and the errors are not documented at all so its a guessing game or waiting weeks for any kind of support.




hi HyperDiskhead ,


appricaite that you have tried Snap Center 1.0.1 and tried SQL backups. Sorry to hear that you had trouble to get things right. 


Yes VSC workflow error will be shown in Snap Center GUI.  


can i know what error you getting in VSC workflow, I can help you to resolve it.





Hey Neerajd,


Thanks for the offer of assistance, I won't turn that down! I have VM quiesced backup jobs configured on production clusters running CDOT 8.3.1 to protect NFS datastores hosting mostly VMs with archive/Snapvault setup to a dedicated 8.3.2 CDOT cluster. Using SnapCenter 1.0.1 for policies integrated into VSC in order to apply Snapmirror labels/Netapp Protection policies to retain these VM consistent snapshots on said archive storage. It worked ok initially but I think as load has increased/client migrated more data to CDOT systems they have begun to fail with various errors.


1. Failed on 'SNAPCENTERVMNAME'. Activity 'Discovering Resources# failed with error: Discover resource enumeration returns null or emtpy

2. Failed on 'SNAPCENTERVMNAME'. Activity 'Unquiescing Applications' failed with error: The operation has timed out

3. Failed on 'SNAPCENTERVMNAME'. Activity 'Creating Snapshot' failed with error: Create snapshot "Snapname" failed: Error: The credentials for the storage system 4. is not configured.. Activity 'Unquiescing Applications' failed with error: the operation has timed out.


I had occurance of error #3 yesterday across most jobs that ran after 11PM, ones running before and one after 8AM for the SnapCenter VM Solely/without Snapvault completed ok. I checked the credentials in both VSC and SC and they were good as expected. I restarted the OnCommand service on the VSC server and restarted the SnapCenter services and it has not reoccured today but some have now failed with error #1. Yestesterday I also reviewed each of the 7 jobs containing 34 datastores in total with Snapvault setup suffering issues and checked schedules due to the above regarding some failing/some completing. I tweaked some where the jobs overran/were running at the same time; however the SnapCenter machine was not busy according to vSphere data it was just encase it helped. Does this sound like it helped or was this a temporary error do you think?

Regarding todays failure for 3 jobs suffering error #1, coincidently yesterday I noticed while trying to edit alert settings for these jobs and another one that is now completing successfully that I cannot save settings due to error "Select the compatible entities for BACKUPJOBNAME Backup Job", for the one job of these which is now working; I removed datastores until I found one that it was complaining about and allowed me to save the job config after removing but I cannot add it back due to the same error. It is an NFS datastore and is available so I'm not sure where to go if you could help with this?









Hi Gareth,


the 3 issue you reported: 


1. Failed on 'SNAPCENTERVMNAME' Activity 'Discovering Resrouces# failed with error: DIscover resource enumeration returns null or empty.

2. Failed on 'SNAPCENTERVMNAME' Activity 'Unquiescing Application' failed with error: The operation has timed out.

3. Failed on 'SNAPCENTERVMNAME' Activity 'Creating Snapshot' failed with error: Create snapshot "Snapname" failed: Error: The credentials for the storage system.


issue 1 and 3 : please make sure SVM(Storage Virtual Machine are added to the VSC). If its already added just do modify and reapply the password. SC will update the Storage connection. 

Note: you need to add the snapvault SVM also in VSC. 



Issue 2: its purely application "quiescing and unquiescing" at load. try again this operation after doing the above changes of storgae connection. 



let me know if its resolves the issue. 





Hi Neerajd,


Thanks for the response, the initial issue was resolved via the steps you mentioned I was just detailing prior issues, but if you below I am having an issue with resources selected now when previously they backed up without error, which when these datastores are not removed it is causing entire jobs to fail and the datastores in question can not be re-added to jobs with the same error.


The below jobs are failing, initially 4 jobs in total were but I removed the "incompatible resource" in question which was a normal datastore previously being backed up without error and that job is now functioning but as stated the DS cannot be added back



Will not let me add DS back:


A screenshot of the error with the SnapCenter machine name removed:





HI Gareth,


Lets have a webex session, let me help you to get this working.


let me know which time zone your work? I m in Pacific standard time(PST). 


Issue describe by you is "disocvery of the resources". 


let me know best time we can have webex. 









Hey Neerajd,


That might be useful to show you thanks, I am in GMT UK time and work 8AM-4:30PM. I do have a technical case open also for the issue adding resources if you want to take ownership but it didn't detail the related backup failures as it was created by a colleague. You can drop me a Webex anytime in these hours if you are available, or if not let me know a good time for you tomorrow perhaps and I will work on this with you from home when convenient.





HI Gareth

I have messaged you. please let me know on that