Data Backup and Recovery

SnapCreator Scheduler not working after upgrade to 4.0

REISTTELECOM
4,571 Views

After the Upgrade to 4.0, we are not able to edit the schedules or create new schedules.

We are running SC on Windows.

Error from gui log:

2013-06-04 16:14:45,945 [1371680565@qtp-1684132543-62] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - Couldn't delete schedule in quartz

2013-06-04 16:14:45,945 [1371680565@qtp-1684132543-62] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - Couldn't delete schedule in quartz

2013-06-04 16:14:45,945 [1371680565@qtp-1684132543-62] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - Validating job

2013-06-04 16:14:45,945 [1371680565@qtp-1684132543-62] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - Validating job

2013-06-04 16:14:45,945 [1371680565@qtp-1684132543-62] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - Creating job schedule

2013-06-04 16:14:45,945 [1371680565@qtp-1684132543-62] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - Creating job schedule

2013-06-04 16:14:45,945 [1371680565@qtp-1684132543-62] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - Create job schedule failed

2013-06-04 16:14:45,945 [1371680565@qtp-1684132543-62] com.netapp.snapcreator.ui.service.SnapCreatorGUILogger ERROR - Create job schedule failed

Does anybody have a solution for this problem?

21 REPLIES 21

ktenzer
4,519 Views

In 4.0 RBAC is different can you go into user management and check your permissions or ensure you are the SC administrator? Also a screenshot from the GUI and the error would be helpful.

Regards

Keith

REISTTELECOM
4,156 Views

Hi Keith,

I am logged in as administrator so this shouldn’t be an issue (but I already doublechecked it).

Here is the screenshot from the error in the GUI. The error message is similar when trying to create a new schedule.

REISTTELECOM
4,517 Views

Found another issue. When running jobs, SC is not able to get the snapvault update status and fails the job.

ktenzer
4,517 Views

For your second issue please attache the debug logs from the running operation under scServer4.0.0/logs/<profile>

For the first issue we need the engine.log and sc_server.log under scServer4.0.0/logs in addition to that we also need you to zip the scServer4.0.0/snapcreator and attach it.

We will get through this and thanks for your patience

Keith

ktenzer
4,517 Views

You can also do --action scdump which gathers all the logs

Keith

REISTTELECOM
4,517 Views

Hi Keith,

you got mail .

Should we do the conversation within the community or is it OK to send you mails directly?

ktenzer
4,517 Views

Lets do all communications here please, attach everything I requested to community post. I need the logs from scdump and the scServer4.0.0/snapcreator directory and everything under it.

Regards,

Keith

REISTTELECOM
4,517 Views

Hi Keith,

attached are the requested files

ktenzer
4,517 Views

Awesome thanks we are looking at this and will get back to you.

Last thing can you provide exact steps you followed when you upgraded? It looks like something went wrong with upgrade so we are trying to reproduce steps that would or could cause this.

Thanks for all the help!

Keith

REISTTELECOM
3,945 Views

- set all config files to not encrypt password

- saved 3.6 config files folder

- stopped SnapCreator server service

- saved 3.6 db files (complete snapcreator folder including subdirectories and files)

- uninstalled 3.6

- installed 4.0 (start as service, custom port 8081)

- stopped SnapCreator server service

- copied backuped config and snapcreator to new location (C:\Program Files\NetApp\Snap_Creator_Framework\scServer4.0.0\engine)

- ran update (java -jar snapcreator.jar -update) > no errors

- started SnapCreator server service

If you want to, we can go back to 3.6 immediately and do the upgrade again to reproduce the error, as I have a snpshot before the upgrade.

BR Stephan

Arora_Kapil
3,945 Views

Hi,

Please let us know which of the following step was performed after stopping the newly installed 4.0 SC server:

1) Deleted new 4.0 'snapcreator' folder and then copied the 3.6 snapcreator folder?

or

2) Overwrote the 4.0 'snapcreator' folder with 3.6 snapcreator folder.

If you follwed step 2 that might have caused a merge and resulted in curruption.

Please can you try try step 1 and let us know? (if that was not done the first time)

Just delete 4.0 'snapcreator' folder, copy the one from 3.6, and run upgrade.

- ran update (java -jar snapcreator.jar -update) > no errors

- started SnapCreator server service

Kapil

REISTTELECOM
3,945 Views

I did it like 1)

justints
3,945 Views

Could you please share the 3.6 snapcreator database(ie gui\snapcreator folder before the upgrade) ?

REISTTELECOM
3,945 Views

I reran the upgrade an noticed, that there is obviously something wrong with the database upgrade (see screenshot).

I also attached the db before upgrade

BR Stephan

justints
3,946 Views

Are you running the upgrade on the same machine than ran snapcreator 3.6 server? has the locale been changed??

REISTTELECOM
3,103 Views

Yes, same machine. Locale has not been changed.

justints
3,103 Views

Attached is a upgraded snapcreator database, could you try with this one?

REISTTELECOM
3,101 Views

Sorry, but I had to downgrade to 3.6 to get my backup jobs running.

I will try it again another time

ktenzer
3,102 Views

Ok we are working on this and definitely see an issue. We think the problem is that you have German local and the dates were not able to be converted because of this. Obviously this is an upgrade bug and an issue on our end, I do apologize about this.

We are going to manually fix your 4.0 DB and try and send it back to you, then things should work. Otherwise we will continue to look into this bug and of course provide a fix but that could take some time.

Regards,

Keith

pascalc
2,702 Views

Is this gonna be an issue also with french windows server locale ?

Public