Data Backup and Recovery

SnapManager SQL Job Scheduled with SQL Agent fails on cluster

DAIRYMILK

Hi all,

I've just installed SnapManager SQL 5.2 on Windows 2008 R2 with SQL 2008 R2 SP1 running in 2 node "active/active" cluster (one instance per node under normal operation)

It all works fine, I can do backups, remote verifications no problem.  However, whenever I try to schedule a job using a SQL Agent job, it fails.  I've used earlier versions of SnapManager with 2003 clusters and don't recall ever having this problem.  Either way, the error is as follows:

Details: new-backup cmdlet will exit as it is not running in the Active node: SRV-SQL-01. The current node: CLS-SQL-01. SQL Server: CLS-SQL-01\VSPHERE. SQL Instance: CLS-SQL-01\VSPHERE

SRV-SQL-01 is the physical node.  CLS-SQL-01 is the clustered instance.

The backup command is as follows:

"C:\Program Files\NetApp\SnapManager for SQL Server\SmsqlJobLauncher.exe" new-backup  –svr 'CLS-SQL-01\VSPHERE'  -ClusterAware -ver  –verInst SQL-VER-01' -mp –mpdir 'C:\Program Files\NetApp\SnapManager for SQL Server\SnapMgrMountPoint' -RetainBackupDays  5 -lb -bksif -RetainSnapofSnapInfoDays 5 -rudays 5 –mgmt standard

If I run this manually from a command prompt on the physical host SRV-SQL-01, it works.  When SQL Agent launches it, it fails with the error above.

Anyone have any ideas?

1 ACCEPTED SOLUTION

spat

If you have active/active or active/active/active cluster, at the end of the backup setup you need to select no for the dialog box and don’t let SMSQL add -clusteraware to the command.  This is the bug and we aware of it at this  point.

View solution in original post

16 REPLIES 16

miguel_maldonado

Hello Pat,

I found the same error and followed your instructions to solve it. We are wondering if there is an official KB that supports your recommendation?

Thank you and regards,

Miguel

spat

This has been stated in SMSQL 5.2 manual on page 71 as follows: "

In earlier versions of SnapManager, the jobs that are scheduled to run against a

server are not required to reside in the same server. In SnapManager 5.2, the jobs

that are targeted to run against a server need to be scheduled in that particular

server's scheduler."

nick_ellis

Hi,

I get the same error on my new cluster  (SQL2008R2 SP1). I am not trying to upgrade any job, just creating a new one.

I am able to perform a back up from within SMSQL or if I just paste the command in command prompt but it fails if it runs under SQL Agent.

Henryk

spat

You should be able to create a job from SMSQL 5.2 and have it create a job and schedule the job afterward.

nick_ellis

Hi Spat,

That's what I am doing. The only difference I have just noticed is that my physical node name is not the same as SQL node.

This is what I get:

Details: new-backup cmdlet will exit as it is not running in the Active node: Server1. The current node: Node1. SQL Server: Node1\Node1. SQL Instance: Node1\Node1

Would this make any difference?

Thanks,

Henryk

spat

That is the situation with SMSQL 5.2.  If you go back to the earlier post in this thread, you will see that SMSQL 5.2 have to run on the active node.  This is not an issue with the previous version.

nick_ellis

So, does this mean that if I want to retain that functionality I will have to downgrade SMSQL?

What version of SMSQL supports this?

spat

This is an expected behavior for SMSQL 5.2.  In the previous version of SMSQL, you are not suppose to be able to do this but you can.  The reason being is that we don't want MSSQL job to get confuse or interupt with each other command.

spat

If you like, please contact me at pat.sinthusan@netapp.com so I can try to help you further in this situation.

spat

If you have active/active or active/active/active cluster, at the end of the backup setup you need to select no for the dialog box and don’t let SMSQL add -clusteraware to the command.  This is the bug and we aware of it at this  point.

View solution in original post

DAIRYMILK

Hi everyone, sorry for the delay in replying, I was on holiday last week.

spat - I can confirm that if I remove the -clusteraware option from the SQL agent job, it works as expected.  If this is the solution, I will do this as I would rather have the SQL agent run the job than use a scheduled task.  The job will move with the instance and I have scheduled my SQL jobs to run at different times so they won't conflict if both instances are on the same node.

it does seem that we're having the same issue here.  I'd also rather use SQL jobs, scheduled tasks work OK but each time the job tries to run on the node that isn't active, you get a nasty red error in the event log.  Plus the scheduling is better in SQL IMO

spat

Yes that is the solution.  SMSQL 5.2 will not allow to execute the backup from nonactive node.

nick_ellis

In that case I won't be able to run my backups from SQL.

Are you going to re-enable this in the future versions of SMSQL?

DAIRYMILK

Update - I have configured scheduled tasks instead which means the backups run but I would still like to know why the SQL agent jobs don't!

crocker

  is this one that your team handles or should the question be asked in the NetApp Support Community?

jausch

I've forwarded this to the SQL folks.

Announcements
Register for Insight 2021 Digital

INSIGHT 2021 Digital: Meet the Specialists 2

On October 20-22, gear up for a fully digital, totally immersive virtual experience with a downright legendary lineup of world-renowned specialists. Tune in for visionary conversations, solution deep dives, technical sessions and more.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public