Data Backup and Recovery

xcp initial configuration

jporetsky
4,341 Views

In the process of setting up xcp to copy from our original to a new filer. Required as the original has language of 'C' and it needs to be 'US_eng'

 

I am absolutely not understanding where to configure the catalog. It _reads_ like it can be a directory on the server I am running xcp from. I put the directory in xcp.ini where the directory is on a local disk.

catalog = /opt/NetApp/xFiles/xcp/catalog

 

The command and error:

[root@utility-mgmt-004 xcp]# /opt/fdsys/xcp/xcp/linux/xcp scan -newid mgmt1-scan acffdsyssquibxnas-proddev-lif10:/vol/qa_mgmt
XCP 1.9.1; (c) 2023 NetApp, Inc.; Licensed to Sean Beverley [US Government Publishing Office] until Tue May 30 11:14:40 2023

xcp: ERROR: mount '/opt/NetApp/xFiles/xcp/catalog': invalid path '/opt/NetApp/xFiles/xcp/catalog'
Job ID : Job_2023-03-14_13.22.22.632801_scan
Log Path : /opt/NetApp/xFiles/xcp/xcplogs/Job_2023-03-14_13.22.22.632801_scan.log
STATUS : FAILED

 

What am I missing. I have already verified rw in the destination filer.

 

 

14 REPLIES 14

Ontapforrum
4,217 Views

I see that the error is pointing to - invalid path in your setup. Could you verify if the solution listed applies to your issue.

 

Could you check this: (Go to last section of the listed XCP Issue)
https://docs.netapp.com/us-en/xcp/xcp-troubleshoot-xcp-nfs.html#xcp-issues-and-solutions


Issue:
xcp:ERROR: invalid path 'IP:/users009/user1/2022-07-01_04:36:52_1489367

 

Solution:
If there is a colon (:) in the file path, use three colons (:::) instead.

 


Related Kbs on XCP tool: (For SMB only)
No, NetApp XCP migration tool for SMB does not support a catalog feature as it does for NFS.
https://kb.netapp.com/Advice_and_Troubleshooting/Data_Storage_Software/NetApp_XCP/Does_NetApp_XCP_SMB_support_a_catalog_feature%3F


https://library.netapp.com/ecm/ecm_download_file/ECMLP2865035

 

jporetsky
4,328 Views

Nope. As should be clear from the end of the second paragraph, there are no colons in the xcp.ini

jporetsky
4,327 Views

For clarity we are a 100% linux/nfs environment.

elementx
4,319 Views

I also found that poorly explained. You can create NFS share and export it from one of the NFS boxen, e.g. at the DR site, and use that as catalog location.

 

[xcp]
catalog = dr:/data/catalog
...

 

jporetsky
4,317 Views

Didn't make a difference. Tried with one and three colons.

 

/etc/exports:

/opt/NetApp/xFiles/xcp/catalog utility-mgmt-004(rw)

 

[root@utility-mgmt-004 xcp]# /opt/fdsys/xcp/xcp/linux/xcp scan -newid mgmt1-scan acffdsyssquibxnas-proddev-lif10:/vol/qa_mgmt
XCP 1.9.1; (c) 2023 NetApp, Inc.; Licensed to Sean Beverley [US Government Publishing Office] until Tue May 30 11:14:40 2023

xcp: ERROR: Catalog inaccessible: Cannot mount dr:::/opt/NetApp/xFiles/xcp/catalog
Failed with 'socket connect to 'dr tcp 111 b'pmap2' c0': [Errno -2] Name or service not known'

xcp: HINT: Verify the settings in the host config file /opt/NetApp/xFiles/xcp.

Job ID : Job_2023-03-14_14.52.25.705106_scan
Log Path : /opt/NetApp/xFiles/xcp/xcplogs/Job_2023-03-14_14.52.25.705106_scan.log
STATUS : FAILED

elementx
4,312 Views

In my case the NFS server where I hold the catalog is dr.local, and the NFS export is /data/catalog, so I use dr:/data/catalog.

In your case you may need a valid hostname and an export you can write to.

"Name or service not known" indicates the hostname "dr" cannot be resolved, so maybe use the right IP or hostname of your NFS server where the catalog share is available. Also try to manually mount it with `sudo mount -t nfs ...` to make sure it's usable and writeable as regular NFS share (before XCP service is started). Normally it doesn't have to be manually mounted, but it' s a good idea to try and unmount before attempting to use XCP.

jporetsky
4,311 Views

I just am not getting this. I have the directory created, in /etc/exports and exported:

[root@utility-mgmt-004 xcp]# exportfs
/opt/NetApp/xFiles/xcp/catalog
utility-mgmt-004.gpo.gov

 

xcp does not appear to see it. And @elementx do you mean should I see if i can mount the mgmt-004 export _on_ mgmt-004?

elementx
4,309 Views

Yes, if you create that export and chmod -R 777 that directory, then I'd have it configured like this:

 

[xcp]

catalog = utility-mgmt-004:/opt/NetApp/xFiles/xcp/catalog

 

If utility-mgmt-004 isn't in DNS, add it to /etc/hosts so that it resolves.

 

And then try to mount manually from the XCP system:

 

sudo mkdir /mnt/test

sudo mount -t nfs utility-mgmt-004:/opt/NetApp/xFiles/xcp/catalog /mnt/test 

sudo touch /mnt/test/test.txt

 

If OK, umount that share and use XCP.

 

That's how I got it to work last time I tried.

If this doesn't work, I will try tomorrow using the latest release.

jporetsky
4,300 Views

I admit to being confused and annoyed by the requirement for an nfs mount for a local file.

elementx
4,299 Views

It's  not a local file, e.g.

a) XCP node is utility-mgmt-003

b) NFS servers are utility-mgmt-002 (PROD) and utility-mgmt-004 (DR site)

 

In this scenario Catalog would be on an NFS export at DR site.

I think the reason Catalog is on external (source, target, or some other) NFS share is that multiple XCP nodes can access it at the same time.

If you can't get this to work as I described, I'll try tomorrow using the latest XCP version.

Ontapforrum
4,293 Views

Sometimes, it can get little frustrating, but keep trying.

 

Looks like  you are giving location  of catalog on this linux box- [root@utility-mgmt-004 xcp]# ?

 

So, as per the requirement - The catalog will need to be on a NetApp Filer. The catalog should be stored on a NetApp volume with export permissions matching the the actual sources and targets.

 

Once the catalog location is given on the NetApp filer. You can run this command:

[root@localhost /]# ./xcp show XX.XX.XX.XX [NetApp filer]

 

it should give an output like...

== Attributes of NFS Exports ==
drwxr-xr-x --- root root 4KiB 4KiB 6d2h xx.xx.xx.xx:/
drwxr-xr-x --- root root 4KiB 4KiB 6d2h xx.xx.xx.xx:/catalog_vol
drwxr-xr-x --- root root 4KiB 4KiB 1h30m xx.xx.xx.xx:/source_vol

 

If it does not see the 'catalog', then you need to enabled 'showmount'.
https://kb.netapp.com/Advice_and_Troubleshooting/Data_Storage_Software/NetApp_XCP/NetApp_XCP_show_command_returns_no_exports_for_storage_server

 

Page-10/18/:
https://library.netapp.com/ecm/ecm_download_file/ECMLP2865035

 

jporetsky
4,294 Views

I think I got it. It's returning "FAILED" but I think that this is for

Stats : 4,733 scanned, 4,729 indexed, 4 errors

 

Going to try a copy and a second FS

elementx
4,281 Views

That may be insufficient perms on some of the files at source, or maybe at destination, but the catalog thing seems OK now.

Drew_C
2,654 Views

@jporetsky Just checking in to see if there's a solution here. Several things have been suggested, but its unclear if any of them helped get XCP working for you as expected.

Community Manager \\ NetApp
Public