Data Infrastructure Management Software Articles and Resources

Command Example - Refresh OnCommand Info


This command will initiate a general refresh of the information in OnCommand for a specified Storage Controller.

This command will generally be useful when you are integrating WFA with OnCommand.  If WFA creates the storage components, it is necessary to have OnCommand refresh it's information so it recognizes those new storage components prior to having WFA initiate any OnCommand tasks.

WFA - B5499

Please Note:

All content posted on the NetApp Community is publicly searchable and viewable. Participation in the NetApp Community is voluntary.

In accordance with our Code of Conduct and Community Terms of Use, DO NOT post or attach the following:

  • Software files (compressed or uncompressed)
  • Files that require an End User License Agreement (EULA)
  • Confidential information
  • Personal data you do not want publicly available
  • Another’s personally identifiable information (PII)
  • Copyrighted materials without the permission of the copyright owner

Continued non-compliance may result in NetApp Community account restrictions or termination.



I added this command to my 'Create Volume' workflow. When I try to enter "default" value for any of "Enable / Array / DFMIp" fields in the "Edit Workflow" window I get the following error message: see the screenshot attached.

Do you have an idea what's that?Screenshot-2.png


No, not really.  I'm not  certain why you're getting that error.  I tried importing it into another WFA VM I have and it seems to work fine... through new workflow creation, preview, etc.

Can you tell me which version of WFA you are using?  Also, what browser?  I did export this from WFA  I've tried imports to the same version and the latest (, and don't seem to have this issue.  Out of curiosity, have you tried the same actions with a different browser?


I'm running WFA w/ IE 9.0.8112.16421

It's weird as I can't reproduce the error myself atm ..

Another question: in what DFM log file do I see requests from WFA host?

My workflow invoking "refresh oncommand info" seems to work fine but I think DFM cache doesn't really get refreshed.


All Community Forums