Data Infrastructure Management Software Discussions

Re: BUG? ISSUE? OCI Configuring Cognos for Report Distribution by Email

Case opened. 
#2005463616

 

 

Re: BUG? ISSUE? OCI Configuring Cognos for Report Distribution by Email

Hey Giacomo,

 

I have been travelling this week, so I haven't had the chance to look at your case notes. Hopefully you have been made aware that we now understand the root issue, and have been given access to the workaround via NetApp support.

 

Basically, OCI 7.0.1 / 7.0.2 have a Java path issue with the DWH, where when the OCI DWH is installed to a path without a space character in it. This results in the wrong internal install of Java being used by Cognos, which does not have the special .jar files that allow Cognos to unlock, manipulate and save the Cognos configuration file - editing the Cognos configuration to store the SMTP server settings is the most common way of running into this issue.

 

Taking care to install the DWH to a path with a space in it will avoid this issue - on US English, "Program Files" is a default.

 

Support has been given a procedure from OCI engineering to remediate OCI 7.0[1-2] installs being impacted by this. I will follow up on this post when I am certain when this issue will be fixed in future OCI releases, and which future OCI releases are known to contain this fix

 

Matt

Re: BUG? ISSUE? OCI Configuring Cognos for Report Distribution by Email

Good news bad news Matt! :-)

 

I use i.e. d:\sanscreen to simplify localization of files Smiley Happy and there's a bug for this...great.

 

Ok, I'll do the backup of dwh db, reinstall everything with a preceding "Program Files" or maybe "SAN Screen" (joking).

 

Thank you,

 

 

 

 

 

Re: BUG? ISSUE? OCI Configuring Cognos for Report Distribution by Email

Giacomo,

 

A reinstall shouldn't be necessary. I think there is an easier workaround, by just copying the missing files over to the correct directory. I've tried it in my lab and it worked for me.

I just don't know if the workaround has been officially approved. Let me try to find out before sharing it here in case the solution hasn't been provided to you already in the case you opened.

 

Regards,

Gerhard

Re: BUG? ISSUE? OCI Configuring Cognos for Report Distribution by Email

Hi Gerhard,

 

that's good.

Can you provide more detailed informations (what to copy and where)?
I could do it.
Regards,

 

Re: BUG? ISSUE? OCI Configuring Cognos for Report Distribution by Email

Hi Giacomo,

 

turns out OCI Engineering created a batch file you can run in the environment to fix the issue (attached).

 

Regards,

Gerhard

Re: BUG? ISSUE? OCI Configuring Cognos for Report Distribution by Email

Thank you very much!

 

Regards,

 

 

Forums