Data Infrastructure Management Software Discussions

Highlighted

Error when creating a command

NetApp Alumni

I was attempting to save a new command and got this error:

Validation failed for classes [com.netapp.wfa.command.model.CommandParameterMapping] during persist time for groups [javax.validation.groups.Default, ]

List of constraint violations:[

ConstraintViolationImpl{interpolatedMessage='may not be empty', propertyPath=objectName, rootBeanClass=class com.netapp.wfa.command.model.CommandParameterMapping, messageTemplate='{org.hibernate.validator.constraints.NotEmpty.message}'}]

Thank-you,

   - Rick -

5 REPLIES 5
Highlighted

Re: Error when creating a command

NetApp

Hey Rick,

Can you provide more information.

What is the command about?

What are the parameters?

Attach screenshots if possible for the error and the "parameter mapping" tab.

Looks like there is something wrong with the parameter mapping

Highlighted

Re: Error when creating a command

NetApp Alumni

Hi Anil,

Unfortunately, lost the WFA connection, and will have to redo the command.  I'll re-post here if I get the same error.

Regards,

   - Rick -

Highlighted

Re: Error when creating a command

Hi Rick,

When developing a command and providing command parameter mapping details.the ObjectName column cannot be empty. If it happens to be empty, then this specific message can come as shown in the following screenshot.

Some more details on command parameter mapping is in this thread:

https://communities.netapp.com/message/112605#112605

Thanks,

Shailaja

View solution in original post

Highlighted

Re: Error when creating a command

NetApp Alumni

Thanks Shailaja.

Maybe it should be an enhancement to report empty object name for parameter x.

Regards,

   - Rick -

Highlighted

Re: Error when creating a command

That's right Rick. We have filed the bug to enhance the error messages that come out in the command parameter mapping area.

Thanks,

Shailaja

Check out the KB!
NetApp Insights To Action
All Community Forums