Data Infrastructure Management Software Discussions

Highlighted

Grafana - SVM/Volume doesn't show data after rename of SVM on NetApp

Hello,

 

our customer reported that in Grafana for a few volumes no data is shown. After investigating the problem we found out that the problem occurs on all svm's which have been renamed on NetApp. These SVMs were shown in Grafana with the old and the new name, but only in the old SVM Name we can see metrics. 
We already tried to move all data to the new SVM name and remove the old SVM folder, but as soon as we restart the netapp-harvest manager the old folder is created and all data is shwon under the old SVM Name.

 

Is it possible to get the information in Grafana shown in a correct way, after SVMs had been renamed on the NetApp.

Greets,

Torsten

3 REPLIES 3
Highlighted

Re: Grafana - SVM/Volume doesn't show data after rename of SVM on NetApp

Hi Torsten,

Harvest should update its instance cache every 1 hour or after restart, so normally this shouldn't happen. Can your customer run Harvest in foreground mode and check whether the output metrics contain the old or new SVM names?

 

Starting Harvest in foreground/verbose mode:

./netapp-worker -poller POLLER -v

Or to get only the output metrics:

./netapp-worker -poller POLLER -v | grep "M="

(Replace POLLER with the poller name).

Highlighted

Re: Grafana - SVM/Volume doesn't show data after rename of SVM on NetApp

Hello Vachagan,

 

I will try your commands and will give you feedback as soon as I could reach the customer.

 

Best regards

Torsten

Highlighted

Re: Grafana - SVM/Volume doesn't show data after rename of SVM on NetApp

Hello Vachagan,

we checked your commands, and in all pollers we can only see the new SVM names.
The old SVM names are never shown anywer in the pollers.

 

Greets,

Torsten

Check out the KB!
Knowledge Base
All Community Forums