Data Infrastructure Management Software Discussions

Highlighted

Grafana don't show any metrics

Hey all,

 

We have installed 3 Servers:

1x Grafana

1x Graphite

1x NetApp Harvest

 

We can see that Harvest delivers the data to the graphite server. We see the data under /opt/carbon/whisper/netapp/poller/perf/<groupname>/<clustername>


The test of the connection from Grafana to Graphite under datasources is also successfull. But we don't see any data in the dashboards.


I checked multiple logfiles and I have no idea where the issue is located.

 

Could someone help me with that?

 

Regards

Matthias

5 REPLIES 5

Re: Grafana don't show any metrics

I found the issue. graphite web pointed to another directory.

Re: Grafana don't show any metrics

Hello,

can you suggest which config files were pointing to different files?

thanks

 

Re: Grafana don't show any metrics

Config files are not the issue, it's the path to the counter data that is expected by Grafana. The default is /opt/graphite/storage/whisper/netapp/{perf, capacity}. So in this situtation, you can either (1) change the graphite/carbon path, (2) you can create symbolic links or (3) you can change the paths in Grafana dashboards.

Re: Grafana don't show any metrics

In my case the config of graphite-web was not pointing to the right whisper folder.

 

I installed graphite via the yum package and changed the path from /var/lib/... to /opt/... but did not change the web config file.

Re: Grafana don't show any metrics

I have another issue, which I don't understand.

 

If I open the SVM dashboard I can see the groups the clusters, the SVMs and so on.

 

If I open the cluster dashboard, I can see the groups and nothing more.

 

Do you have an idea what the issue could be?

Forums