Data Infrastructure Management Software Discussions

Harvest 1.4 worker not running

adimitropoulos

root@harvest:/opt/netapp-harvest# ./netapp-worker -poller XXXX -daemon
[2020-08-12 13:12:27] [NORMAL ] WORKER STARTED [Version: 1.4] [Conf: netapp-harvest.conf] [Poller: XXXX]
root@harvest:/opt/netapp-harvest# ./netapp-worker -poller XXXX -v
[2020-08-12 13:12:34] [NORMAL ] WORKER STARTED [Version: 1.4] [Conf: netapp-harvest.conf] [Poller: XXXX]
[2020-08-12 13:12:34] [WARNING] Started in foreground mode; messages to STDERR are redirected to the logfile and are not visible on the console.
[2020-08-12 13:12:34] [DEBUG ] [conf] Line [29] is Section [global]
[2020-08-12 13:12:34] [DEBUG ] [conf] Line [30] in Section [global] has Key/Value pair [grafana_api_key]=[eyJrIjoiRWpHZFNaTm1wNTJXbE4zWXpqTFlXZXZJVVp5RWF1NkQiLCJuIjoibmV0YXBwLWhhcnZlc3QiLCJpZCI6MX0=]
[2020-08-12 13:12:34] [DEBUG ] [conf] Line [31] in Section [global] has Key/Value pair [grafana_url]=[https://localhost]
[2020-08-12 13:12:34] [DEBUG ] [conf] Line [36] is Section [default]
[2020-08-12 13:12:34] [DEBUG ] [conf] Line [37] in Section [default] has Key/Value pair [graphite_server]=[192.168.0.10]
[2020-08-12 13:12:34] [DEBUG ] [conf] Line [43] in Section [default] has Key/Value pair [auth_type]=[ssl_cert]
[2020-08-12 13:12:34] [DEBUG ] [conf] Line [44] in Section [default] has Key/Value pair [ssl_cert]=[netapp-harvest.pem]
[2020-08-12 13:12:34] [DEBUG ] [conf] Line [45] in Section [default] has Key/Value pair [ssl_key]=[netapp-harvest.key]
[2020-08-12 13:12:34] [DEBUG ] [conf] Line [61] in Section [default] has Key/Value pair [hostname]=[XXXX]
[2020-08-12 13:12:34] [ERROR ] [conf] No poller section for -poller [XXXX] found; please check your config file

1 REPLY 1

Re: Harvest 1.4 worker not running

adimitropoulos

Ignore, i managed to fix it.

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums
Public