Data Infrastructure Management Software Discussions

NABox - Busiest Average Port Utilization

nicholsongc

This may just be a database anomaly but I'm seeing really skewed percentage in my "Busiest Average Port Utilization" frame on the following dashboard:

 

Netapp: Detailed Network Port / Highlights 

 

Examples (this is true for ALL Groups/Clusters being monitored by this (and my only) instance of NABox

 

DC.jpgSV.jpgeUS.jpgEMEA.jpgLA.jpg

 

If this is just a matter of deleting some superfluous directories then I'm no stranger to that task.  I'll just need to know which ones to target.  Other than that I'm all on this one.

 

Thank you

Greg

5 REPLIES 5

Re: NABox - Busiest Average Port Utilization

christsai

Harvest 1.4.1 have a bug for ethernet port utilization statistics

 

You can try this hotfix to fix issue

 

"BUG miscalculating link_speed which breaks ethernet port utilization statistics."
https://community.netapp.com/t5/OnCommand-Storage-Management-Software-Discussions/NetApp-Harvest-1-4-1-Hotfix-to-fix-2-bugs/td-p/144160

Re: NABox - Busiest Average Port Utilization

nicholsongc

OK... if you could indulge this Windows weenie and provide some guidance on running the script I really appreciate it.

 

I have the patch in place in /tmp but my linux CLI knowledge falls short to complete the rest of the process.

I am logged into the NABox server as ROOT and cd'ed to /tmp.  I suppose I need to 'sudo' in order to run the patch, etc.

 

Thanks in advance!

Greg

Re: NABox - Busiest Average Port Utilization

christsai

Hi @nicholsongc

 

1. Copy the file to /tmp/ (or any other folder) on your Harvest server.
2. Stop Harvest
     $ service netapp-harvest stop
3. Run the file:
If Harvest is installed in default location (/opt/netapp-harvest/), simply run in terminal:
     $ ./harvest_hotfix_14100
If otherwise Harvest is in another location, provide Harvest path as argument, e.g.:
     $ ./harvest_hotfix_14100 /home/admin/netapp-harvest/
4. Read the output and see if the update was successful
5. Restart Harvest
      $ service netapp-harvest start

https://community.netapp.com/t5/OnCommand-Storage-Management-Software-Discussions/NetApp-Harvest-1-4-1-Hotfix-to-fix-2-bugs/td-p/144160

Re: NABox - Busiest Average Port Utilization

nicholsongc

When I log in as ROOT I get the "#" prompt not the "$" prompt.  So with the hotfix copied to /tmp...

 

root@NABOX01:/tmp# ls -l
total 24
-rwxrwxrwx 1 root root 9412 Dec 21 09:28 harvest_hotfix_14100
drwxr-xr-x 3 root root 4096 Nov 12 10:14 harvest_version_temp
-rw-r--r-- 1 root root 275 Nov 12 10:19 issue.new
drwx------ 2 root root 4096 Nov 12 09:36 vmware-root

I get this when I run # service netapp-harvest stop

 

Failed to stop netapp-harvest.service: Unit netapp-harvest.service not loaded.

 

and this when I run # ./harvest_hotfix_14100

 

/usr/bin/env: python3: No such file or directory

 

 

 

Re: NABox - Busiest Average Port Utilization

christsai

Hi @nicholsongc

 

I get this when I run # service netapp-harvest stop

 

Failed to stop netapp-harvest.service: Unit netapp-harvest.service not loaded.

 

You can try to use 

$ /etc/init.d/harvest stop

 

and this when I run # ./harvest_hotfix_14100

 

/usr/bin/env: python3: No such file or directory

 

Please install python3 before install hotfix

$apt update

$apt install python3

 

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums
Public