Data Infrastructure Management Software Discussions

NetApp-Harvest cDot Poller Stop Working

Hi

I have the current setup for NABOX:

 

Debian GNU/Linux 8 (jessie) (8.7) Visit Web Page

NetApp SDK v9.4
Harvest v1.4
Grafana v4.6.3
Graphite v1.2.0
Elasticsearch 5.6.5
Logstash 1:5.6.5-1

 

I have 7-mode and cDot data being collected.

The 7 mode pollers are working fine and collecting.

With cDot however, i have to stop/start the pollers daily, as they stop working.

The NABOX still shows them working but, when looking at the Grafana Poller screen, i can see there are no metrics being collected.

Once i stop/start the poller, i can then see them working after a few mins.

 

To investigate this further, i started one of the cDot pollers in verbose mode. Below ive pasted a few messages ive picked out.

 

This message comes up when starting the poller in verbose:

[xxxxxxxxx] key [site] is depreciated; aliasing to [group]. Rename [site] to [group] to remove this message.

 

The next set of messages is from /opt/netapp-harvest/log, from the cdot poller log

Argument "1000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "10000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "10000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "10000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "100M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "1000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "1000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "100M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "1000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "1000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "1000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "1000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "10000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "1000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "10000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "10000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "10000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "1000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "10000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "10000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "10000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "10000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "10000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.
Argument "1000M" isn't numeric in numeric gt (>) at /opt/netapp-harvest/netapp-worker line 1633.

 

 

When the poller stops working, the last set of messages are:

[2018-09-25 17:02:08] [DEBUG  ] [lun] Starting new poll data batch [0 to 8 of 8], batch size is [500]

 

nothing further

3 REPLIES 3

Re: NetApp-Harvest cDot Poller Stop Working

Check out the Harvest 1.4.1 .  It contains some fixes to the collections stopping unexpectedly.  I updated my Harvest with the new zip file and it was pretty painless.    This also adds some additinal FlexGroup features.

Re: NetApp-Harvest cDot Poller Stop Working

Hi Thanks for the reply. As soon as i posted this, i id notice that a newer version of Netapp Harvest was released. So yes, i have upgraded to this version. However, the poller issue for cDot still continues

Re: NetApp-Harvest cDot Poller Stop Working

Unfortunately Harvest 1.4.1 doesn't fix this issue properly (mea culpa). But I will provide a patch to fix that soon. I recommend to upgrade to 1.4.1 and stay tuned for the patch.

 

And if you face other issues, please let us know 🙂

Cloud Volumes ONTAP
Review Banner
All Community Forums
Public