Data Infrastructure Management Software Discussions

Networking in OnCommand 5 (protection manager)

Hi all,

We have recently upgraded from Protection Manager 4.0.1 to OnCommand 5.0.

Some notes...

  • All of our filers have a mangement port and a backup interface.
  • All the filers have the option ndmp.preferred_interface set to the backup interface.
  • All of our filers have the hostPreferredAddr1 set to the backup interface in OnCommand

Most of the relationships that were created by 4.0.1 look like this

host.domain:/voll/volumename/qtree nearstore.domain/vol/volumename_backup/qtree

host.domain resolves to the management address NOT the backup interface.

This all worked in 4.0.1 as it just used the ndmp.preferred_interface to run the backup.

Now we have upgraded to OnCommand 5.0, it seems to be trying to update the relationship as is, ie. run the backup via the management port which is blocked.

How do we force OnCommand 5.0 to use the backup interface?




Networking in OnCommand 5 (protection manager)

Hi Braiden,

     This most likely looks like a regression caused in 4.0.2 do you have case created ?




Networking in OnCommand 5 (protection manager)

Yes I have a case# 2002536781. That would be disappointing, because it seems like a very likely use case of the product.

Networking in OnCommand 5 (protection manager)

We still haven't got to the bottom of this with support. I have run up a fresh installation and the same problem. It is interesting OnCommand recognises what interface it should use then ignores it!

dfpm job detail 30

*data omitted*

Event Id:      415

Event Status:  normal

Event Type:    job-progress

Job Id:        30

Timestamp:     28 Sep 2011 09:32:43

Message:       Retrieved preferred interfaces (

Error Message:

*data omitted*

Event Id:                         420

Event Status:                     normal

Event Type:                       rel-create-progress

Job Id:                           30

Timestamp:                        28 Sep 2011 09:32:44

Message:                          Creating backup relationship with vz4aixsas09:/vz4aixsas09_unstr_test01/test01 via the default interface

Error Message:

Source Volume or Qtree Id:        3157

Source Volume or Qtree Name:      vz4aixsas09:/vz4aixsas09_unstr_test01/test01

Destination Volume or Qtree Id:   0

Destination Volume or Qtree Name: bbsq01a:/testb_06/vz4aixsas09_unstr_test01_test01

Bytes Transferred:                0

Networking in OnCommand 5 (protection manager)

Solved this problem by trial and error on some options

ndmpDataUseAllInterfaces              1

This option allowed DFM to use/try more than the default data interface. It now works correctly