Data Infrastructure Management Software Discussions

No performance data shown in ocpm/ocum

Hi community,


we have installed a new FAS2650 and I want to monitor the health an performance data with ocpm and ocum.


I first installed the ocum and afterwards the ocpm. The ocpm is fully integrated into the ocum and it seems to work fine. The ocum is able to poll all the neccessary information, but the ocpm only get the health status of svm, lun, etc ... There are no performance data (iops/mbps) available.


Additional to that, i get an error message (Pairing status: Bad -> Performance Poll failed): The credentials provided by Performance Manager for the user with Event Publisher role are either incorrect or Performance poll is not complete or has failed.


The crendetials must be ok, because I tried it more then one time and I tried it with the admin user and a dedicated event publisher user. Nothing seems to work.


Do someone know, if there exist a connection or extended log? Or do I have to enable a special function on the FAS2650 to get performance data in the ocpm? Help would be appreciated!


FAS2650: ONTAP Cluster Mode 9.1P7

OCUM: 7.1P3

OCPM: 7.1P3



best regards


Re: No performance data shown in ocpm/ocum

Hi, TrippleAAA,



After OCPM/OCUM 7.1 were leased, the two products have been merged into one product. We have since released both OCUM 7.2 and OCUM 7.3, so it would be much easier to install and manage. You might consider downloading and installing the latest versions.



On your current installation, can you check these couple of issues:


1. How did you add the cluster? Did you add it separately to OCPM and OCUM before the two were integrated, or added to OCUM afterwards? 

2. Did you reboot the OCPM after you connected it to OCUM?




View solution in original post

Re: No performance data shown in ocpm/ocum



The latest versions of OCUM supports all supported versions of ONTAP. So OCUM 7.3 GA will support your ONTAP 9.1 environment.


We encourage our users to download and install the latest versions of the OCUM which has better support for ONTAP.


We will be working on raising awareness on product availability and support.



Re: No performance data shown in ocpm/ocum

Hey guys,


thanks for your fast response.


I logged in to my netapp-account and under software -> OnCommand Unified Manager (for VMware vSphere) I was just able to download version 7.1, so I thought it is the newest one.


I will try your solution, download version 7.3 and install that one.


I will give you respones on monday, if that works.


best regards

Re: No performance data shown in ocpm/ocum

Hi guys,


i have chosen "VMware vSphere" from the drop-down menu of OnCommand Unified Manager dowload website. When I choose "7.2 and above", I am able to download 7.3 ova template. I haven't seen that the first time I downloaded ocum. That's the reason, why I startet with version 7.1.


Now I have installed version 7.3 and it's working without problems. Now I get all the health and performance data. Thanks for your help, I really appreciate that!


I just have one more question:


When I have a look at the information page of a netapp-node, there are some information about the flash-cache module (NVMe ssd). But the status of the flash-cache is "NOT_MAPPED". Does anyone know, if that is a problem?



Netapp - Flash-cache information.png


@juliad What I forget to say is, that I first installed ocum and then ocpm. Afterwards I started the integration process of ocum and ocpm. The last step was to add the cluster once to ocum and it was automatically mapped to ocpm as well. I restartet both server, but still no perfromance data. But now with ocum 7.3 it's working great.



Thanks a lot and best regards

Re: No performance data shown in ocpm/ocum



Very glad that UM 7.3 worked for you!


As to your question regarding the status of the flash-cache is "NOT_MAPPED", this in itself it's not a problem. If reflects that the state of your flash-cache configuration.


It is a problem, however, if your flash-cache IS mapped and here it say "NOT_MAPPED".





Re: No performance data shown in ocpm/ocum



again, thank you for the fast and good answer. I'm glad that it is not a problem.


I wish you all a nice week and best regards!

Re: No performance data shown in ocpm/ocum



I had the same issue on the OCPM 7.1P3 but  due to reasons I couldn''t  upgrade based on compliancy (IMT) and other depended application (snapprotect)


For that I created a support case and we found a bug KB related to this.


The issue is, that the countermeasure files downloaded from the NetApp systems/Cluster are not handled due to a missing TMP folder on the OCPM server.


After creating the folder the OCPM is functional again.



Re: No performance data shown in ocpm/ocum

Hi henk_ruis,


thanks for sharing the post with us. Maybe that was the problem.


I can't try your solution, because I already deleted the old ocum/ocpm virtual machines and I don't want to reinstall them again. And the cluster is already connected to the new ocum, but maybe it will help other people.


best regards

Re: No performance data shown in ocpm/ocum

No problem, that was my intention, to help other people with this information;-)

Because it took some time with support to find this solution and that is something I wish to nobody.

No disregard to NA support they helped me perfectly.

Re: No performance data shown in ocpm/ocum



I can confim this is the solution. Many thanks for your helpful information.



Re: No performance data shown in ocpm/ocum

Nice, but some Kudos would also be fine.

Cloud Volumes ONTAP
Review Banner
All Community Forums