Data Infrastructure Management Software Discussions

OnCommand System Manager 3.1.1 will not start

Windows 7 64-bit

Java JRE 1.7.0_67


IE 10




New install.  Reboot after install.


Have tried changing default browser.  No errors on screen. 


This was in the Application logs:


Source:  SharpShell

BoxContextMenuClient: Query Context Menu for items C:\Program Files\NetApp\OnCommand System Manager\SystemManager.exe



Re: OnCommand System Manager 3.1.1 will not start

Nevermind.  My system has an AMD chip.


I wish the apps were more compatible with other things.


I have some apps that won't work with Java 7.  Now I have to go back to Java 7.  And now I need a new system for managing NetApp *sigh*


Coming to the conclusion that everything I add to my environment requires a standalone management station.

Re: OnCommand System Manager 3.1.1 will not start



You can check the following steps,

 1.  Application launch failure – check for supported browser.

 2.  In case of blank screen during application launch, that is, the browser launches but the application will not load – check for the JRE version, whether JRE is installed or not, check for a supported browser,      and check for error messages in the application installation dir, that is, bootlog.log. Alternatively, check in the users home directory for the presence of Oncommand System Manager for appropriate permissions.

 3.  In case the application has been installed once and then reinstalled, check for JRE versions.

 4.  When there are user-specified dedicated ports for OnCommand System Manager and if OnCommand System Manager is not closed properly, an application launch failure might occur. To fix this, identify  the   java process in use. Reboot the client machine that will clear the zombie process.

 5.  During installation, if the creation of a desktop icon fails or it is not possible to launch the application by clicking on the desktop icon, launch the application by double-clicking SystemManager.exe or by    running the java -jar SystemManager.jar in the command prompt. Both SystemManager.exe and SystemManager.jar are present in the installation directory.

 6.  Application launch failure with error:
       Port is in use by other application
    During installation, if a static port number is specified to launch the OnCommand System Manager and while launching the application, if the port is used by some other application, then the launch will fail. Uninstall the application and then re-install by specifying the port that is not used by any other application or select the automatic port selection option for OnCommand System Manager to select a free port.

 7.  Application launch failure with the following error:
    'Error while starting Jetty denied: listen'
    Add the following values for a new Windows environment variable in the Advanced tab of the System Properties window:
    Variable name: _JAVA_OPTIONS
    Variable value:
    Then, restart OnCommand System Manager.



If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: OnCommand System Manager 3.1.1 will not start

I had the same issue a few weeks ago. Try deleting the install file and reinstalling.

Re: OnCommand System Manager 3.1.1 will not start

The problem was that I was trying to install on an AMD system.  The AMD chipset is not supported.


Thanks for the feedback.  Hopefully, it will help someone else who has already checked the pre-requisites. 

Re: OnCommand System Manager 3.1.1 will not start

On my computer, win 8.1 64 freshly installed it wouldnt install because there is java 8 aldo java 7 is also installed, when I removed java 8 only java 7 32 and 64 it installed with no errors but now it is not starting at all, and it does not log nothingye in win logs... I try remove and reinstall even copy from another computer, nothingue... What do I do this is really a pain i cant dedicate a machine just to use system manager???

Re: OnCommand System Manager 3.1.1 will not start

New install on Windows 7 (Intel processor) is having the same issue. When I run "C:\Program Files\NetApp\OnCommand System Manager\SystemManager.exe" nothing happens. It just instantly dies.

Re: OnCommand System Manager 3.1.1 will not start

For me it works when i select the "C:\Program Files\NetApp\OnCommand System Manager\SystemManager.jar" instead of the .exe for start.


Re: OnCommand System Manager 3.1.1 will not start

Thanks! That does seem to work!

Re: OnCommand System Manager 3.1.1 will not start

That worked for me! Thanks!