Data Infrastructure Management Software Discussions

OnCommand Unified Manager 6.4RC1 Upgrade error

Just run the in place upgrade on our 6.3 box , all completed successfully with no errors, however now getting this when attempting to load the page

 

Reverse proxy doesn't have a mapping for the url for resource : '/' with method 'GET'

 

 

Any ideas ?

20 REPLIES 20
Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

Hi,

 

I think, your machine doesn't have full FQDN configured. Whats your host OS ? Is it Windows, vApp or RHEL ?


If it is vApp or RHEL, can you please execute the following commmands and share the output.

 

hostname

ping `hostname`

ping6 `hostname`

 

Try to make entries into /etc/hosts with FQDN host name, and reboot the box.  Post the reboot, this error is expected to be fixed.

It it sill persists, please share your /etc/hosts config as well.

 

Regards,
Saravanan

Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

Hi THanks for your reply

 

its the VM vApp version.

 

So I will need to login as diag user into the OCUM Vapp box and run those commands ?

 

/etc/hosts needs to be edited on the OCUM box with its own hostname ?

 

THanks

Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

ocm.png

 

 

Output as requested.

Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

hosts.png

Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

Thank you for the output.

 

If it is vApp, we have another solution for that. You can change the hostname via vApp console options.

 

Login to the vApp via SSH with maintenance user account.

Go to options 3 -> 11.

You can enter the new hostname, and go for option 10 to reset server certificate.

Then reboot the vApp as suggested in the output of option 10.

 

This will help you to fix this problem.

 

Regards,

Saravanan

View solution in original post

Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

Hi, we have exact the same error, and followed your steps. Unfortunately this did not resolve the problem.

regards

Olaf

Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

Worked for me 🙂

 

Back up and running.

 

just changed name via mena to FQDN and updated the cert as suggested.

 

Back in business...nor for OPM 😉

Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

Hi GROOVE, can you please post your hosts file with the OCUM working again?

regards,

Olaf

Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

Hi ,

perhaps you can help again, we still get the error:

"Reverse proxy doesn't have a mapping for the url for resource : '/' with method 'GET'"

regards,

Olaf

Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

Hi Olaf,

 

Can you please share the content of your /etc/hosts file

 

Did you reset the certificate after the host name change from "OnCommand" to "OnCommand.<domain_name>" ?

 

If possible, can you please share the last few lines of /var/log/ocum/rp-<date>.log ?

 

Regards,

Saravanan

 

Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

Hi,

 

if found these lines in the metioned rp log file:

 

2016-02-26T15:05:18.278Z - error: Validation Errors are: [ { param: 'ip',
    msg: 'value is not a valid IP',
    value: 'OnCommand.domain.local' },
  { param: 'ip',
    msg: 'value is not a valid FQDN',
    value: 'OnCommand.domain.local' } ]
2016-02-26T15:05:18.278Z - error: IP Error
2016-02-26T15:05:18.278Z - error: FQDN Error

 

 

Host file looks like this:

 

127.0.0.1       localhost
127.0.1.1       OnCommand.domain.local OnCommand
::1             localhost ip6-localhost ip6-loopback
fe00::0         ip6-localnet
ff00::0         ip6-mcastprefix
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters

 

(real names changed ...)

 

regards,

Olaf

Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

Thanks Olaf for the output.

 

I understand that you have changed the hostname.

 

Is it really "OnCommand.domain.local" or you named it like that here to secure your actual domain name from our visibility ?

If so, I can also use "OnCommand.domain.local" in my local lab, and try to repro your error.

 

Other than that, I have other 3 questions:

1. Did you reset the server certificate post the hostname change ?

2. Did you reboot your box post the hostname change ?

3. For the domain name you used in the hostname, did you configure the right DNS server in your host configuration ?  Can you check your /etc/resolv.conf and get back ?

 

Sorry for asking more questions, but I want to see where the problem in the configruation.

 

Regards,

Saravanan

Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

Hi msaravan,

 

Is it really "OnCommand.domain.local" or you named it like that here to secure your actual domain name from our visibility ?

Yes i changed the actual domain name for security reasons.

 

1. Did you reset the server certificate post the hostname change ?

Yes

 

2. Did you reboot your box post the hostname change ?

Yes

 

3. For the domain name you used in the hostname, did you configure the right DNS server in your host configuration ?  Can you check your /etc/resolv.conf and get back ?

Yes, I can successfully resolve hostnames in the actual domain. But only on diagnostics console, not at maintenance console (Menue 2 + 10).

 

btw. in the meantime I also opened a case at official netapp support ...

 

regards,

Olaf

Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

So have both OCM and OPM upgraded now. BUt configuring Full integration is still eluding me.

 

I get the new Dash in OCM , but the following is showing unde the cluster - 

 

Pairing Status : Bad

 

Ive gone through setting up the pairing in OPM again , setup new accounts with the correct roles ( admin and Event Pub ) but just cannot seem to get them talking.

 

I take it when in Full integration mode there is no longer a way to go to the OPM URL directly as I am seeing a dertificate error if I do.

 

Andy

Highlighted

Re: OnCommand Unified Manager 6.4RC1 Upgrade error

Thank you olaf. I hope the support team will take care of.

 

I assume yours is a upgrade scenario, and not a fresh installation.

As a last try, can you please share the below data to come to a conclusion:

 

1. Output of /opt/netapp/essentials/data/app_regitry.json

2. The last few lines of log /var/log/ocum/ocumserver-debug.log  - where you could see some put/post requests sent.I want to see those relevant lines.

 

Regards,

Saravanan

Check out the KB!
NetApp Insights To Action
All Community Forums