Data Infrastructure Management Software Discussions

Option setting not possible


I'm currently working on a little configuration robot for migration purposes - 7mode. There it is necessary to set option "ndmpd.enable" on the vfiler (yes vfiler!!). While other options like "httpd.enable" work fine with the current command structure, it is not possible to modify this option.

Result: Unable to set option: ndmpd.enable

Same thing happens on PowerShell command line, in WFA environment. It seems it's not possible work with this option at all.

Any ideas?

Thanks all,



Re: Option setting not possible

try using the Invoke-NaSsh command:

connect-WFAController -Array filer1

invoke-nassh "vfiler run vfiler1 options ndmpd.enable on"

I tried that on a test vFiler from the Powershell cmd and it worked fine.

You could also probably connect to the vfiler and then run the command without "vfiler run vfiler1" part but the above command worked for me.



Re: Option setting not possible

Hi Dieter,

Have you tried to run the command on the controller / vFiler and was that successful?  Just trying to get a levelset and isolate if this is actually a WFA problem or a controller / vfilter configuration problem.  As Tim indicated, it SHOULD work for all environments from WFA.  I'm suspecting that there might be a slight configuration adjustment that might be needed for the controller / vfiler you're working with.



Re: Option setting not possible

Hi Tim,

that's a good idea as a workaround.




Re: Option setting not possible

Hi Kevin,

of course I tried that and a lot of other stuff, including different filer and vfilers, other options, syntax variations in Powershell and also some Ontap versions. No way to set ndmpd.enable option.



Re: Option setting not possible

Hi and TWIMC,

in the meanwhile I've found out to the set the option in a different and very easy way using "Enable-nandmp" command from WFA environment. Thus problem is resolved while it still unclear, why it's not possible to use the options setting method.



View solution in original post

Re: Option setting not possible

Hey Dieter,

Looking at what you're trying to do, you may want to check out the Day-0 workflow example, if you haven't already.  It doesn't do much with vfilers, but it may have some content in there you could use.  For example, there is a WFA command in there for enabling NDMP using Enable-NaNdmp already.



Re: Option setting not possible

Hi Dieter,

The cmdlet Set-NaVfilerProtocol uses the ZAPI vfiler-allow-protocol which allows the usage of certain protocols on the vfiler (for example: nfs, cifs, rsh, iscsi).

The cmdlet Enable-NaNdmp executes the CLI command ‘ndmpd on’ which starts the ndmpd service.

Allowing the usage of a protocol using Set-NaVfilerProtocol does not necessarily enable the related service.  For example, a newly created Vfiler ‘tmp’ will have the cifs protocol allowed, however you still need to run ‘cifs setup’ (Set-NaCifs) to configure and enable the CIFS service.

PS C:\Users\Administrator> Get-NaVfilerProtocol -Name tmp

AllowedProtocols DisallowedProtocols

---------------- -------------------

{nfs, cifs, rsh, iscsi} {}

PS C:\Users\Administrator> $global:CurrentNaController.Vfiler = "tmp"

PS C:\Users\Administrator> Test-NaCifs


Similarly, you need to use Enable-NaNdmp to start the ndmpd service.

In summary, the options setting method is used to set protocols only but not enable the service.Enabling the service is done via different commands.

Hope this helps,


Cloud Volumes ONTAP
Review Banner
All Community Forums